Results 1 to 5 of 5

Thread: I just can't connect a form to email :(

  1. #1
    Join Date
    Aug 2005
    Posts
    63
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default I just can't connect a form to email :(

    Hi all,

    I'm really hoping to find a solution to something which is now driving me crazy... I'm not a coder, not close, though have been getting help from a friend to try an implement some code to get a form connecting to an email...
    how hard can it be? hopefully not to hard

    As it stands I've a form with the following two top lines of code

    <form action="/scripts/emailMoo.asp" method="post">

    <input name="_recipients" type="hidden" value="purpleapplepie@yahoo.com" />

    the file emailMoo.asp is replicating the code from http://www.hosting-support.pipex.net...d/formmail.txt

    I've put in the following

    referers = Array("bhbgroup.co.uk")
    mailComp = "CDOSYS"
    smtpServer = "intmail.atlas.pipex.net"
    fromAddr = "username_goes_here"

    cdoConfig.Fields("http://schemas.microsoft.com/cdo/configuration/smtpserver") = "intmail.atlas.pipex.net"
    cdoConfig.Fields("http://schemas.microsoft.com/cdo/configuration/smtpserverport") = 25
    cdoConfig.Fields("http://schemas.microsoft.com/cdo/configuration/sendusing") = 2
    cdoConfig.Fields("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate") = 1
    'You need to edit the next two lines
    cdoConfig.Fields("http://schemas.microsoft.com/cdo/configuration/sendusername") = "username_goes_here"
    cdoConfig.Fields("http://schemas.microsoft.com/cdo/configuration/sendpassword") = "password_goes_here"

    I also added to the form the required field of '_recipients' and set it you my email as such:
    <input name="_recipients" type="hidden" value="purpleapplepie@yahoo.com" />
    though am getting a results

    Web Fusion the host say the account has been set up properly and aren't willing to offer any other help

    I'd really appriciate any thing you can offer

    cheers,
    elliot

  2. #2
    Join Date
    Jun 2005
    Location
    英国
    Posts
    11,876
    Thanks
    1
    Thanked 180 Times in 172 Posts
    Blog Entries
    2

    Default

    Your SMTP server should be set to smtp.yahoo.com, methinks.
    Twey | I understand English | 日本語が分かります | mi jimpe fi le jbobau | mi esperanton komprenas | je comprends franšais | entiendo espa˝ol | t˘i Ýt hiểu tiếng Việt | ich verstehe ein bisschen Deutsch | beware XHTML | common coding mistakes | tutorials | various stuff | argh PHP!

  3. #3
    Join Date
    Aug 2005
    Posts
    63
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Hi Twey, the smtp setting were from the host company I'm using webfusion

    Am I able to use the one you suggested instead, and how come it's a Yahoo smtp? this is all very foreign to me

    thanks

  4. #4
    Join Date
    Jun 2005
    Location
    英国
    Posts
    11,876
    Thanks
    1
    Thanked 180 Times in 172 Posts
    Blog Entries
    2

    Default

    Depends on the address you're using. If you're sending from an @yahoo.com address, use smtp.yahoo.com (although I now notice that that address was for the recipient, not the sender).

    At any rate, the SMTP server you were attempting to use (intmail.atlas.pipex.net:25) refuses connections, although the host exists. I suggest you ask them to give you a correct SMTP server.
    Twey | I understand English | 日本語が分かります | mi jimpe fi le jbobau | mi esperanton komprenas | je comprends franšais | entiendo espa˝ol | t˘i Ýt hiểu tiếng Việt | ich verstehe ein bisschen Deutsch | beware XHTML | common coding mistakes | tutorials | various stuff | argh PHP!

  5. #5
    Join Date
    Aug 2005
    Posts
    63
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks Twey, that's helpful to know. I'll contact my host to explain this and see where I get from there.. hopefully all will be resolved

    many thanks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •