Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: Video player set up

  1. #1
    Join Date
    Nov 2011
    Location
    Cider Region
    Posts
    955
    Thanks
    121
    Thanked 3 Times in 3 Posts

    Default Video player set up

    Evening,
    This is the page in question, http://www.theremotedoctor.co.uk/clo...rollto=content

    I have removed the old player & its files from the page and inserted the following.

    Code:
    <h1>
    <video id="video" class="shadow">
    <source id="mp4" src="videomp4/cloning-programming.mp4" type="video/mp4">
    </video>
    </h1>
    Could you advise the setup for it to start to play on its own once you arrive on this page.
    The video is 700x578
    Last edited by theremotedr; 01-09-2017 at 10:34 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    chertsey, a small town 25 miles south west of london, england.
    Posts
    1,094
    Thanks
    1
    Thanked 205 Times in 201 Posts

    Default

    Hi there theremotedr,


    try it like this...
    Code:
    
    <video id="video" class="shadow" autoplay="autoplay">
     <source id="mp4" src="videomp4/cloning-programming.mp4" type="video/mp4">
    </video>

    coothead
    ~ the original bald headed old fart ~

  3. The Following User Says Thank You to coothead For This Useful Post:

    theremotedr (01-05-2017)

  4. #3
    Join Date
    Nov 2011
    Location
    Cider Region
    Posts
    955
    Thanks
    121
    Thanked 3 Times in 3 Posts

    Default

    Thanks.
    As you can see ive taken it from here http://www.theremotedoctor.co.uk/clo...rollto=content

    Now just need to make the adjustments so its 700x578 & the border,basically to match the page i took it from.

    Also the recycle code so when it finishes it just loops again "constant playing loop"

  5. #4
    Join Date
    Nov 2006
    Location
    chertsey, a small town 25 miles south west of london, england.
    Posts
    1,094
    Thanks
    1
    Thanked 205 Times in 201 Posts

    Default

    Hi there theremotedr,

    why have you wrapped the video in a "h1 element"?

    It is inappropriate and very poor coding.

    There should only be one "h1 element" per document and
    that should be used for a page title, logo or banner.

    Further reading:-


    coothead
    ~ the original bald headed old fart ~

  6. #5
    Join Date
    Nov 2006
    Location
    chertsey, a small town 25 miles south west of london, england.
    Posts
    1,094
    Thanks
    1
    Thanked 205 Times in 201 Posts

    Default

    Hi there theremotedr,


    for looping try it like this...
    Code:
    
    <video id="video" class="shadow" autoplay="autoplay" loop="loop">
     <source id="mp4" src="videomp4/cloning-programming.mp4" type="video/mp4">
    </video>

    coothead
    ~ the original bald headed old fart ~

  7. #6
    Join Date
    Nov 2011
    Location
    Cider Region
    Posts
    955
    Thanks
    121
    Thanked 3 Times in 3 Posts

    Default

    Now changed.
    Would i need to put the video into its own div so its 700x578 as opposed to its large display now & its radius edges ?

  8. #7
    Join Date
    Nov 2006
    Location
    chertsey, a small town 25 miles south west of london, england.
    Posts
    1,094
    Thanks
    1
    Thanked 205 Times in 201 Posts

    Default

    Hi there theremotedr,

    it does not need an h1 or a div, you already have it in a container.

    This is how the HTML should look...

    Code:
    
    <section id="content"> 
    <video id="video" class="shadow" autoplay="autoplay" loop="loop">
     <source id="mp4" src="videomp4/cloning-programming.mp4" type="video/mp4">
    </video>
    </section>
    ...and this is how your CSS should look...

    Code:
    
    .shadow {
        margin: 1em 0;
        border-style: 1px solid #000;
        box-shadow: 6px 6px 8px #000;
    }

    coothead
    ~ the original bald headed old fart ~

  9. #8
    Join Date
    Nov 2011
    Location
    Cider Region
    Posts
    955
    Thanks
    121
    Thanked 3 Times in 3 Posts

    Default

    I couldn't find the appropriate css file for this container.
    I wanted to see why it's not 700x578 like it should be.
    I thought putting it on its own code would cover it & wasn't sure if anything was using the same code.

  10. #9
    Join Date
    Nov 2006
    Location
    chertsey, a small town 25 miles south west of london, england.
    Posts
    1,094
    Thanks
    1
    Thanked 205 Times in 201 Posts

    Default

    Hi there theremotedr,

    you will find it on line #531 of your "normalize.css" file.

    If you don't want to alter or use it from there, then
    remove the class name of the "video element"
    altogether and, using the existing id, add the CSS to
    an appropriate file of your choosing.

    HTML

    Code:
    
    <section id="content"> 
    <video id="video" autoplay="autoplay" loop="loop">
     <source id="mp4" src="videomp4/cloning-programming.mp4" type="video/mp4">
    </video>
    </section>
    CSS

    Code:
    
    #video {
        max-width: 43.75em;
        margin: 1em 0;
        border: 0.06em solid #000;
        box-shadow: 0.5em 0.5em 0.5em #000;
    }

    coothead
    Last edited by coothead; 01-05-2017 at 11:40 PM.
    ~ the original bald headed old fart ~

  11. #10
    Join Date
    Nov 2011
    Location
    Cider Region
    Posts
    955
    Thanks
    121
    Thanked 3 Times in 3 Posts

    Default

    Hi,
    Come to a halt so off to bed & see if i can pin point the issue in the morning.

    Page in question http://www.theremotedoctor.co.uk/clo...rollto=content

    HTML used,
    Code:
    <section id="content"> 
    <video id="movavivideo" autoplay="autoplay" loop="loop">
    <source id="mp4" src="videomp4/cloning-programming.mp4" type="video/mp4">
    </video>
    </section>
    CSS used & placed in the Normalize.css file line 608
    Code:
    #movavivideo {
        max-width: 43.75em;
        margin: 1em 0;
        border: 0.06em solid #000;
        box-shadow: 0.5em 0.5em 0.5em #000;
    }

Similar Threads

  1. php video player
    By resnostyle in forum PHP
    Replies: 5
    Last Post: 01-12-2013, 11:37 PM
  2. Video Player
    By Rain Lover in forum Flash
    Replies: 1
    Last Post: 11-17-2009, 02:26 AM
  3. music and video player- PHP (?)
    By d-machine in forum PHP
    Replies: 1
    Last Post: 08-18-2009, 01:29 PM
  4. Video Player Script
    By ngaps in forum Looking for such a script or service
    Replies: 0
    Last Post: 06-18-2009, 01:17 AM
  5. Video player
    By remp in forum Other
    Replies: 10
    Last Post: 09-25-2007, 02:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •