Results 1 to 5 of 5

Thread: IPhone, IPad... etc Not showing background images

  1. #1
    Join Date
    Sep 2004
    Location
    Little Falls, Roodepoort, South Africa
    Posts
    411
    Thanks
    4
    Thanked 1 Time in 1 Post

    Default IPhone, IPad... etc Not showing background images

    Hi All you clever CSS folks

    On my website in my style.css I specify some background that show is various places on the page, it works 100% on everything else except IOS (iPad, iPhone's etc).

    Can anyone suggest how I can rectify this??

    Thanks in advance

    Code:
    #header {
    	background-image: url(../../img/steback.jpg);
        background-repeat: no-repeat;
        -o-background-size: cover;
        -moz-background-size: cover;
        -webkit-background-size:cover;
        }
        
    #services {
    	background-image: url(../../img/about.jpg);
        background-repeat: no-repeat;
        -o-background-size: cover;
        -moz-background-size: cover;
        -webkit-background-size:cover;
        color: white;
    }
    
    #contact {
    	background-image: url(../../img/newsletter-bg.png);
    	background-repeat: no-repeat;
        -o-background-size: cover;
        -moz-background-size: cover;
        -webkit-background-size:cover;
        color: white;
    	background-color: #405162;
    Last edited by simonf; 11-04-2016 at 12:08 PM.
    Very Best Rgds, Simonf :cool:
    __________________________________
    My Site | E-Mail Me

  2. #2
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    3,035
    Thanks
    25
    Thanked 599 Times in 575 Posts
    Blog Entries
    40

    Default

    In what way doesn't it work?

    And a demo would be helpful to illustrate the undesirable behaviour.
    Focus on Function Web Design
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps

  3. #3
    Join Date
    Sep 2004
    Location
    Little Falls, Roodepoort, South Africa
    Posts
    411
    Thanks
    4
    Thanked 1 Time in 1 Post

    Default

    HI Beverly

    Thanks again

    OK.. so on a msdevice (Laptop etc, Firefox, Chrome etc) looks like this=

    Click image for larger version. 

Name:	ste-720x405.jpg 
Views:	52 
Size:	34.5 KB 
ID:	5970

    Android Smartphone (Samsung, BB etc all OK)

    Click image for larger version. 

Name:	Screenshot_20161106-140931.jpg 
Views:	50 
Size:	94.6 KB 
ID:	5971

    With IOS device (iPad, iPhone as you will see the background images is missing (all the other images on the pages are 100%, i.e pics of houses etc)

    Click image for larger version. 

Name:	IMG_20161106_140852.jpg 
Views:	56 
Size:	86.4 KB 
ID:	5972

    Website is http://www.silvertreeestates.co.za/ if anyone wants to see full site

    rgds,Simon
    Very Best Rgds, Simonf :cool:
    __________________________________
    My Site | E-Mail Me

  4. #4
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    3,035
    Thanks
    25
    Thanked 599 Times in 575 Posts
    Blog Entries
    40

    Default

    What I would do in your shoes is create a test page copy that you can strip back to the single element +CSS that contains the image. Test it, and if the problem isn't there, start adding back markup and CSS is logical blocks, testing between each addition, until you find the thing that creates the problem. Leave the scripts til the end and add them back one by one too. You should get to a point where you can identify what is causing the problem and then you'll be able to concentrate on fixing it.
    Focus on Function Web Design
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps

  5. #5
    Join Date
    Sep 2004
    Location
    Little Falls, Roodepoort, South Africa
    Posts
    411
    Thanks
    4
    Thanked 1 Time in 1 Post

    Default

    HI Beverley

    Thanks, that what I'm busy trying at the moment lol, but will feedback if/when I find the issue.
    Very Best Rgds, Simonf :cool:
    __________________________________
    My Site | E-Mail Me

Similar Threads

  1. Youtube Video Gallery - NOT showing on Ipad or Iphone. Please help.
    By Bizzmaxx in forum Dynamic Drive scripts help
    Replies: 9
    Last Post: 04-16-2016, 10:57 AM
  2. code not working in safari iphone and ipad
    By vinpkl in forum JavaScript
    Replies: 4
    Last Post: 05-14-2015, 12:12 PM
  3. Ultimate Fade In Slideshow--Freezes on ipad and iphone
    By dcarlson in forum Dynamic Drive scripts help
    Replies: 3
    Last Post: 01-26-2013, 07:27 PM
  4. Replies: 3
    Last Post: 07-22-2012, 10:25 PM
  5. AnyLink JS Drop Down - link not working on iDevices (iPhone/iPad)
    By neoboy14 in forum Dynamic Drive scripts help
    Replies: 2
    Last Post: 10-12-2011, 02:32 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •