Results 1 to 3 of 3

Thread: Ultimate Fade-in slideshow (v2.4 through v2.6.1) loading image and other fixes

  1. #1
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,375
    Thanks
    77
    Thanked 3,421 Times in 3,382 Posts
    Blog Entries
    12

    Default Ultimate Fade-in slideshow (v2.4 through v2.6.1) loading image and other fixes

    As previously reported in:

    http://www.dynamicdrive.com/forums/s...188#post260188

    1) Script Title: Ultimate Fade-in slideshow (v2.4 through and including now v2.6.1)

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

    3) Describe problem: Since the loading image has no z-index it's always behind the gallerylayers which even when they have no images in them yet, have a background of black and a z-index of 1000 or 999.

    Here's the new code, a drop in replacement to 2.6.1:

    fadeslideshow.js

    There were a number of other fixes and minor improvements since then that were later 'lost' (except on my hard drive) when my web space was wiped, and some of the forum attachments were deleted (the first is the one mentioned above, it and all others mentioned below are now included in the attached update to v2.6.1):

    //Unofficial Updates: (all March 6 ,2016 - dates below mark their initial working out for version 2.4)
    //Sept 2nd, '11 Update for loading image bug see: http://www.dynamicdrive.com/forums/s...188#post260188
    //Sept 4rth '11 Update for initial mouseover bug in some browsers - first image wouldn't show up if mouse was over the show as page loaded
    //Sept 13th '11 Update for missing first image bug in IE - added onerror to onload for routine that tests first image before getting underway

    //March 7, 2016 Update to prevent taps in most tap capable browsers from activating mouseover pause. Android sometimes still has this problem
    // adding this meta tag may help with that: <meta name="viewport" content="user-scalable=yes">
    Last edited by jscheuer1; 04-01-2016 at 11:58 PM. Reason: scale back update to bug fixes only, later add tap fix, fix broken link
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  2. #2
    Join Date
    Aug 2004
    Posts
    10,138
    Thanks
    3
    Thanked 1,007 Times in 992 Posts
    Blog Entries
    16

    Default

    Sorry for the delay in getting around to this, updated the .js file with your version!
    DD Admin

  3. The Following User Says Thank You to ddadmin For This Useful Post:

    jscheuer1 (04-01-2016)

  4. #3
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,375
    Thanks
    77
    Thanked 3,421 Times in 3,382 Posts
    Blog Entries
    12

    Default

    Hey, thanks. It's your script after all, and I think I was overreaching before.
    Last edited by jscheuer1; 04-02-2016 at 01:17 AM.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Similar Threads

  1. Asynchronous Loading for Ultimate Fade-In Slideshow (v1.51)?
    By howard.a.s in forum Dynamic Drive scripts help
    Replies: 10
    Last Post: 11-04-2013, 04:47 PM
  2. Replies: 3
    Last Post: 09-13-2013, 02:14 AM
  3. ultimate fade in slideshow loading time
    By Rosalie in forum Dynamic Drive scripts help
    Replies: 10
    Last Post: 09-18-2010, 07:05 PM
  4. Ultimate Fade-in slideshow - images not loading
    By peanutville in forum Dynamic Drive scripts help
    Replies: 9
    Last Post: 02-16-2010, 01:14 PM
  5. Ultimate fade in slideshow image loading
    By bode in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 10-04-2008, 01:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •