Results 1 to 5 of 5

Thread: Image Power Zoomer scrunched up image

  1. #1
    Join Date
    Aug 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Image Power Zoomer scrunched up image

    1) Script Title: Image Power Zoomer v1.1

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...owerzoomer.htm

    3) Describe problem: This script (and others like it) always compress vertically in the zoom window. So I can see the larger image, but only when all the way to the left side of the image, and it compressed to a very narrow resolution.

    I have looked at it using firebug, and it appears to be taking my 3000px image and displaying it 200px wide. Height appears to be working just fine. Any thoughts on why it would do that?

    Thanks in advance

    Belgarath the Ancient One

  2. #2
    Join Date
    Aug 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default fixed!

    So after fighting it for a day and finally posting here, of course I fix it 1 minute later. Using the default .css template for a liquid layout, it had the following line, that messed this script up:

    Code:
    img, object, embed, video { max-width: 100%; }
    Anyway, I removed img from the line, and working great now. Maybe this will help someone else down the line.

    Belgarath the Ancient One

  3. #3
    Join Date
    May 2015
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    THANK YOU THANK YOU THANK YOU THANK YOU!!!! I registered for a Dynamic Drive account at midnight just to thank you. I have been pulling my hair out for 3 hours with this exact issue, thinking I was doing something wrong or my website had some kind of conflicting code. I was so pissed. Now I am so happy. My line of code wasn't exactly the same, but I searched in my global CSS file for anything relating to "img" and "100%" and I found this:

    .thumbnail img, .Slideshow img, #imgMfgLogo, img { max-width: 100%; }

    Removed it, problem solved. So relieved... Your good deed was a blessing to me, 3 years after you posted it! =)

  4. #4
    Join Date
    May 2015
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Fix led to another problem...

    Sooo...I just realized that removing that code had some side effects on other images throughout the website. So now I have more troubleshooting to do. I can either have the zoom work and have other images off, or have the zoom broken and have the rest of my images right. Any ideas..?

  5. #5
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    3,033
    Thanks
    25
    Thanked 599 Times in 575 Posts
    Blog Entries
    40

    Default

    Put .thumbnail img, .Slideshow img, #imgMfgLogo, img { max-width: 100%; } back as it was because you can reverse the max-width setting back to default values on power zoomer images.

    Using the example from the demo page,
    Code:
    <img id="myimage" src="ocean.gif" style="width:200px; height:150px" />
    Add this to your stylesheet (underneath the max-width: 100%; line);
    Code:
    #myimage { max-width: none; }
    Change #myimage to the id you've used. Untested but it should work.

    If you need more help, please post a link to your page.
    Focus on Function Web Design
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •