Results 1 to 4 of 4

Thread: Conveyor Belt slideshow script bug

  1. #1
    Join Date
    Oct 2014
    Location
    Hastings, East Sussex
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Conveyor Belt slideshow script bug

    Hi,
    I cannot make this script work, there seems to be a bug in the code, have been trying all day!
    The problem is there is a huge gap between every image and demonstrated here www.tardivader.com
    Please help. I can see this has been a problem for many years and it would have been good to get a solution but although there has been many people in my same situation no update has been published.
    Thank you
    Retfala
    HTML and Script is on here if you right mouse click and view source:
    www.tardivader.com
    and the CSS I used:
    Code:
    div{color:#CF1020; border-width:4px; } 
    img { display: block; float: left; margin:0 auto; }
    a img{text-decoration:none; border: none; }
    
    body {background:#000000; font-family:"Arial"; }
    
    #web-page-base
    {
    width:1000px; 
    height:1000px; 
    margin:0 auto;
    border-style:solid; 
    position:relative; 
    margin-top:100px;
    margin-bottom:100px;
    line-height: 0;
    }
    
    	
    #main-navigation
    {
    width:1000px;
    margin:0 auto;
    position:relative;
    top:65px;
    left:-5px;
    /* background:#000000; */
    /* border-style:solid; */
    }
    Last edited by Beverleyh; 10-27-2014 at 03:00 PM. Reason: formatting

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    In the script, change:

    Code:
    //Specify gap between each image (use HTML):
    var imagegap="<image/maps/hotel1a0.png>"
    to:

    Code:
    //Specify gap between each image (use HTML):
    var imagegap=" "
    And in css/styles.css change:

    Code:
    #temp img, #test2 img, #test3 img {width:1000px; display: inline(; float:left;); } 
    @media screen and (-webkit-min-device-pixel-ratio:0) {
      #temp img, #test2 img, #test3 img {display:table;line-height: 0;width:1000px;float:left;}
    }
    to:

    Code:
    #temp img, #test2 img, #test3 img {width:1000px; display: inline(; float:none;); } 
    @media screen and (-webkit-min-device-pixel-ratio:0) {
      #temp img, #test2 img, #test3 img {display:inline;line-height: 0;width:1000px;float:none;}
    }
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Oct 2014
    Location
    Hastings, East Sussex
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default problem with chrome

    hey just to let you know that when I replied earlier I didn't spot that though the gap had disappeared in Chrome the images where not looping ie it was only displaying one image in rotation so had to add the float left again for chrome (using a hack) and I still have the gap

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    I don't see any changes to the live page (www.tardivader.com) - in other words, as far as I can tell you haven't followed all of my suggestions there. It works fine here in Chrome and others when I do as I suggested. After performing all of those changes, there's no gap between the images and a slight gap (about 3px) between the beginning and end of each loop.

    If you need more help. make the changes as suggested to the live page and tell me what the remaining problem(s) are.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Similar Threads

  1. Re: Conveyor Belt slideshow script
    By Jaguar in forum Dynamic Drive scripts help
    Replies: 5
    Last Post: 03-21-2009, 03:11 PM
  2. Conveyor Belt slideshow script
    By cynthiadkotick in forum Dynamic Drive scripts help
    Replies: 2
    Last Post: 01-24-2007, 12:21 AM
  3. conveyor belt slideshow needs more script?
    By solomon in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 12-03-2006, 02:25 PM
  4. Conveyor Belt slideshow script
    By Niclas in forum JavaScript
    Replies: 1
    Last Post: 08-07-2006, 10:14 AM
  5. Conveyor Belt slideshow script down up NEED HELP!!!
    By superram in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 03-31-2006, 03:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •