Results 1 to 2 of 2

Thread: how to init stickytooltip on postback ?

  1. #1
    Join Date
    Mar 2014
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default how to init stickytooltip on postback ?

    1) Script Title: how to init stickytooltip on postback

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...ckytooltip.htm

    3) Describe problem: I can use stickytooltip on my aspx page and it works fine when loading first time. But on postback the jquery bind to onmouseenter etc. on the images that have data-tooltip attribute does not occur. I need to call the stickytooltip.init again after postback. How do I do that ? NOTE: for some other jquery plugins (http://www.pixedelic.com/plugins/camera/), I could call init functions as below example:
    Code:
    function Camera_mypostback() {
                jQuery('#camera_wrap_1').camera({
                    thumbnails: true,
                    height: '450px'
                });
                return false;
            };
    I am new at jquery so please give code for solution.

  2. #2
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    Is the initialization code for the tooltip being called more than once:

    Code:
    stickytooltip.init("*[data-tooltip]", "mystickytooltip")
    ?

    If so to facilitate this, try finding the line below inside the .js file, and adding the line in red to it:

    Code:
    			if (stickytooltip.stickynotice1.join)
    				stickytooltip.stickynotice1=stickytooltip.stickynotice1.join(' ')
    Then, you should be able to call the init() function more than once on the page without it breaking.
    DD Admin

Similar Threads

  1. StickyTooltip left click
    By Channiro in forum Dynamic Drive scripts help
    Replies: 3
    Last Post: 10-22-2013, 02:30 PM
  2. ddaccordion Menu problem after postback
    By Suseela in forum Dynamic Drive scripts help
    Replies: 2
    Last Post: 02-17-2011, 12:03 PM
  3. Not selecting the correct tab after postback
    By premtemp in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 11-29-2008, 01:47 PM
  4. Swissarmy postback issue
    By jimsnotes in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 04-07-2008, 05:55 PM
  5. Omni Slide in ASP.Net : Disappear after Postback
    By msasono in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 05-14-2007, 03:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •