Results 1 to 3 of 3

Thread: Thumbnail Viewer II Upgrade fails

  1. #1
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Default Thumbnail Viewer II Upgrade fails

    1) Script Title: Thumbnail Viewer II

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...thumbnail2.htm

    3) Describe problem: I have used the original version of this script for a long time. I tried to upgrade to the latest version but cannot get the script to work properly.

    Mouseover does not work, when I click on a thumbnail it opens in a new page.

    I am using jquery 1.6.2 and running the viewer inside PHP so I have had to modify some of the quoting to get the original version to work. The image url and title data come from a mysql database. Here is my original call:
    Code:
    echo "<a href='images/".$row['vfile']."' rel='enlargeimage::mouseover' rev='loadarea' title='&lt;b&gt;".$row['Title']."&lt;/b&gt;&lt;br /&gt;".$row['Medium']." &nbsp; &nbsp; &nbsp; ".$row['iw']." x ".$row['ih']." cm.'><img border='1' src='images/".$row['tnfile']."
    ' alt='' width='".$row['tnx']."' height='".$row['tny']."' class='tn' /></a><br />";
    for the updraded version I have modified this to:
    Code:
    echo "<a href='images/".$row['vfile']."' rel='enlargeimage' rev='targetdiv:loadarea' title='&lt;b&gt;".$row['Title']."&lt;/b&gt;&lt;br /&gt;".$row['Medium']." &nbsp; &nbsp; &nbsp; ".$row['iw']." x ".$row['ih']." cm.'><img border='1' src='images/".$row['tnfile']."
    ' alt='' width='".$row['tnx']."' height='".$row['tny']."' class='tn' /></a><br />";
    Last edited by sabreur; 04-25-2014 at 07:38 AM.

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,070
    Thanks
    44
    Thanked 3,216 Times in 3,178 Posts
    Blog Entries
    12

    Default

    Interesting, looks like it should work. But it's hard to really know without seeing the page. If I had to guess, I would say that either the PHP has some syntax problem and/or that jQuery is interpreting the title field differently than expected. But it could be something else. Like the javascript(s) could be missing or not running for some reason.

    If you want more help, please include a link to the page on your site that contains the problematic code so we can check it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. The Following User Says Thank You to jscheuer1 For This Useful Post:

    sabreur (04-25-2014)

  4. #3
    Join Date
    Jul 2008
    Posts
    17
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by jscheuer1 View Post
    Interesting, looks like it should work. But it's hard to really know without seeing the page. If I had to guess, I would say that either the PHP has some syntax problem and/or that jQuery is interpreting the title field differently than expected. But it could be something else. Like the javascript(s) could be missing or not running for some reason.

    If you want more help, please include a link to the page on your site that contains the problematic code so we can check it out.
    Well, this is embarassing!

    It seems to be working now. As this was a live site, I was copying the faulty page to a new location for you. As so often happens, I took the oportunity to do a little house keeping and removed some redundant javascripts. That seems to have fixed it.

    Thanks, without you I'd still be running V1!

    No the real reason I was updating TNV II was that I was having trouble with it interacting with a popup script. I'll post this as a new thread, not sure whether this is the right forum as it involves TNV II, another jarvascript and php.

    Thanks again.
    "When you are up to your neck in alligators, it is often difficult to remember that the intention was to drain the swamp!"

Similar Threads

  1. Replies: 2
    Last Post: 03-31-2013, 05:21 PM
  2. Thumbnail Viewer 2: disable click and thumbnail alpha
    By seyoo in forum Dynamic Drive scripts help
    Replies: 4
    Last Post: 09-16-2010, 04:05 AM
  3. Image Thumbnail Viewer II Active Thumbnail on Slideshow? (help please) :)
    By SoulieBaby in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 08-11-2008, 12:41 AM
  4. Thumbnail viewer fails to function in IE6
    By bananafiend in forum Dynamic Drive scripts help
    Replies: 4
    Last Post: 06-03-2007, 04:49 AM
  5. Image Thumbnail Viewer - unwanted border around thumbnail images
    By solder_on in forum Dynamic Drive scripts help
    Replies: 4
    Last Post: 05-23-2007, 11:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •