Results 1 to 6 of 6

Thread: CSS Image Gallery description issue

  1. #1
    Join Date
    Apr 2013
    Posts
    18
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default CSS Image Gallery description issue

    1) Script Title: CSS Image Gallery

    2) Script URL (on DD): http://www.dynamicdrive.com/style/cs...image-gallery/

    3) Describe problem:

    Hi all,

    I have gotten the larger images to pop up the way I want (when I click on the thumbnail as opposed to mouse over). My problem is the yellow box that is behind the images sometimes changes to fit the image, sometimes it doesn't. However, on a lot of the images the description that appears below the image either goes below the yellow box, or the bottom of the image is below the yellow box and the descriptions are over the other thumbnails and very hard to read.
    I am hoping someone has an idea on how to force the yellow background to always fit the picture and the description.

    Thanks,
    Shad
    Last edited by shad97; 07-16-2013 at 03:37 PM.

  2. #2
    Join Date
    Apr 2013
    Posts
    18
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    Thanks for the edit. I didn't even realize I had forgotten to include that information.

  3. #3
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,000
    Thanks
    44
    Thanked 3,198 Times in 3,160 Posts
    Blog Entries
    12

    Default

    Sounds like you may have set some dimensions for the span(s), either in the css for:

    Code:
    .thumbnail span
    or (if using onclick activation via selector with pseudo class :focus):

    Code:
    .thumbnail:focus span
    or (if using some other method for click activation and have the default css):

    Code:
    .thumbnail:hover span
    selectors or inline for the spans individually, or somehow somewhere else in your css for the page.

    No dimensions affecting these spans should be set for any of these.

    It might be something else though.

    If you want more help, please include a link to the page on your site that contains the problematic code so we can check it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  4. The Following User Says Thank You to jscheuer1 For This Useful Post:

    shad97 (07-16-2013)

  5. #4
    Join Date
    Apr 2013
    Posts
    18
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    Thank you for the reply. I double checked and there aren't any dimesions set for any of the .thumbnail areas other than the initial .gallerycontainer.
    I don't have the page live yet but I can post the code for the css page and the html page if would help. Just let me know what would help the most.

  6. #5
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,000
    Thanks
    44
    Thanked 3,198 Times in 3,160 Posts
    Blog Entries
    12

    Default

    The best thing would be to put up a live demo. What images are you using though? If they're the ones from the demo page on DD, you could post your HTML and css and I might be able to figure it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  7. #6
    Join Date
    Apr 2013
    Posts
    18
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Default

    I found my issue. Apparently when I put the css code into it's own file I accidentally left the <style> tags in place instead of removing them. After removing them the background box now works properly. If you hadn't suggested checking the dimensions again I probably wouldn't have noticed though.

    Thank you for the help.

Similar Threads

  1. Replies: 0
    Last Post: 06-29-2011, 03:37 PM
  2. iPad issue with CSS Image Gallery hover image enlarge
    By walkoffhomerun in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 06-26-2011, 07:55 PM
  3. Change positions of image description in image gallery
    By arnaudpopi in forum Dynamic Drive scripts help
    Replies: 11
    Last Post: 10-01-2010, 07:24 AM
  4. image gallery issue
    By jrod in forum Dynamic Drive scripts help
    Replies: 2
    Last Post: 11-17-2007, 07:53 AM
  5. CMotion Image Gallery II Issue
    By stereo.fu in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 08-30-2007, 09:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •