Results 1 to 4 of 4

Thread: DD Mega Menu not working only with Windows XP OS

  1. #1
    Join Date
    Nov 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default DD Mega Menu not working only with Windows XP OS

    1) Script Title: DD Mega Menu

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...ddmegamenu.htm

    3) Describe problem: DD Mega Menu does not drop down (not showing) with Windows XP OS (home and professional editions) in all browsers. Works fine with all other OS in all browsers. Any similar problems or suggestions?

  2. #2
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    1,935
    Thanks
    16
    Thanked 303 Times in 302 Posts
    Blog Entries
    11

    Default

    I don't have an XP machine with me at the moment, but from memory, this drop-down worked fine on XP - at least it did the last time I checked.

    Are you referring to the demo page? James (or anyone else with XP access), can you confirm that the demo page is OK in XP please?

    If you mean that your own installation of the script isn't working in XP on your own web page, please provide a link to your page where is its broken.
    Focus on Function Web Design | Latest News RSS | Facebook | Twitter |
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps |
    The only limit to creativity is imagination: JemCon.org

  3. #3
    Join Date
    Nov 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    The demo page is OK.

    I'm using tables for the only drop down (<!--First mega menu (1) -->) in my own installation.

    My Page: http://www.thegiftgallerypromo.com

  4. #4
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    1,935
    Thanks
    16
    Thanked 303 Times in 302 Posts
    Blog Entries
    11

    Default

    Phew! That's a large web page and, at around 4000 lines, too much to go over in detail.

    A few quick-skim observations that may be causing issues;

    The DOCTYPE declaration is inconsistent. As taken from the W3C validator
    The Public Identifier -//W3C//DTD XHTML 1.0 Transitional//EN declares the XHTML 1.0 Transitional document type, but the associated System Identifier http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd does not match this document type.
    You link to 2 jQuery libraries - to version 1.6.4 in the <head>, and version 1.5.2 further down in the <body>, along with the ddmegamenu.css and ddmegamegu.js files, which should go in the <head>, as outlined in the demo page instructions. As for the jQuery - you only need to link to one library and having them both together on the same page is likely to be causing conflicts.

    You also have other CSS styles and JavaScripts dotted throughout the body which could be causing problems.

    I think you should try to clean up the web page as best as you can using the W3C validator http://validator.w3.org/ . Once you restructured things a bit and clean-up the organisation, it should be easier for you to troubleshoot.
    Focus on Function Web Design | Latest News RSS | Facebook | Twitter |
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps |
    The only limit to creativity is imagination: JemCon.org

Similar Threads

  1. DD Mega menu not working in IE 7,8
    By logionweb in forum Dynamic Drive scripts help
    Replies: 6
    Last Post: 01-23-2013, 03:46 AM
  2. DD Mega Menu Help
    By KRAZA1 in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 10-15-2012, 11:49 AM
  3. Resolved DD Mega Menu getting cut off
    By alaska in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 09-04-2011, 02:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •