Results 1 to 7 of 7

Thread: Shockwave 3D Slideshow

  1. #1
    Join Date
    Mar 2007
    Posts
    35
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Default Shockwave 3D Slideshow

    Hi
    i am using the Shockwave 3D Slideshow - unhooked side effect here: http://www.lectronixsales.com/
    While checking it in Firefox 20.0.1 after the second cycle the slideshow stops BUT the slide show disappears, except for the play,pause, etc buttons. Can you please tell me what am i doing wrong because in Chrome it works fine.

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,133
    Thanks
    44
    Thanked 3,229 Times in 3,190 Posts
    Blog Entries
    12

    Default

    Please post about Dynamic Drive Scripts in the Dynamic Drive Scripts Help section here where I've moved this thread, and:

    Warning: Please include a link to the DD script(s) in question in your post. See this post for more information.


    I happen to know of that script. There is a lot of extra stuff on that page that's not needed/used. And it's in quirks mode - not a great idea (may cause problems in IE). But the main problem appears to be that the #wrap selector needs added style for this to work in the Fox:

    Code:
       #wrap {
          width: 750px;
          margin: 0 auto;
          background-color: #fff; 
          position: relative;
          z-index: 0;}
    The browser cache may need to be cleared and/or the page refreshed to see changes.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Mar 2007
    Posts
    35
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Default

    thank you for your quick reply. Where & how do i place the extra styles the wrap selector needs? & what is the fix for IE. kindly let me know.

  4. #4
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    2,025
    Thanks
    16
    Thanked 315 Times in 313 Posts
    Blog Entries
    13

    Default

    Where & how do i place the extra styles the wrap selector needs?
    You'd place John's CSS recommendations (the parts in red) in your stylesheet where indicated (against #wrap).

    & what is the fix for IE. kindly let me know.
    This seems to be the first mention of an IE problem. We are currently working blind. We do not know what script you are using until you provide a link to the source demo page. We cannot offer further guidance without all the information upfront.

    What we need from you
    1. The link to the DD script (which John has already asked you for)
    2. A clear description of what the IE error actually is

    Please provide the information listed above. Until we have this information from you, we cannot offer further help.
    Focus on Function Web Design | Latest News RSS | Facebook | Twitter |
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps |
    The only limit to creativity is imagination: JemCon.org

  5. #5
    Join Date
    Mar 2007
    Posts
    35
    Thanks
    12
    Thanked 0 Times in 0 Posts

    Default

    Link to the script: http://www.dynamicdrive.com/dynamici...wave/index.htm

    Link to the page where i have uploaded the script: http://www.lectronixsales.com/

    i have added the styles: #wrap {
    width: 750px;
    margin: 0 auto;
    background-color: #fff;
    position: relative;
    z-index: 0;}
    as mentioned by John

    but the problem of slideshow disappearing after 10 slides persists in Firefox

    somewhere my coding is wrong , please help.

    thank you.

  6. #6
    Join Date
    Jul 2008
    Location
    Derbyshire, UK
    Posts
    2,025
    Thanks
    16
    Thanked 315 Times in 313 Posts
    Blog Entries
    13

    Default

    The slideshow shops after 10 slides because you have 5 images and the 'maximum-slideshow-cycles' option set to 2 (5 x 2 = 10), so increase the 'maximum-slideshow-cycles' value to a higher number - maybe 100 (I dont imagine anyone will sit through 100 cycles so it will appear continuous).

    I don't see your style revisions in the stylesheet - that's the part between the <style> and </styles> tags toward the top of the page.
    What I do see is some confusion with styles and markup further down - ie;
    Code:
    <div id="wrap"{
          width: 750px;
          margin: 0 auto;
          background-color: #fff; 
          position: relative;
          z-index: 0;} >
    So make sure to remove that ( put it back to <div id="wrap"> ) and make the change in you style declarations only;
    Code:
    #wrap {
     width: 750px;
     margin: 0 auto;
     background-color: #fff; 
     position: relative;
     z-index: 0;
    }
    Also, change the doctype from <html xmlns="http://www.w3.org/1999/xhtml"> to <!doctype html> to get the page out of quirks mode (as John recommended) and that should improve things in IE.
    Last edited by jscheuer1; 05-15-2013 at 12:17 PM. Reason: spelling
    Focus on Function Web Design | Latest News RSS | Facebook | Twitter |
    Fast Edit (A flat file, PHP web page editor & CMS. Small, FREE, no database!) | Fast Edit BE (Snippet Manager) (Web content editor for multiple editable regions!) | Fast Apps |
    The only limit to creativity is imagination: JemCon.org

  7. #7
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,133
    Thanks
    44
    Thanked 3,229 Times in 3,190 Posts
    Blog Entries
    12

    Default

    First make a backup copy of what you have, just in case.

    I've made up a corrected page for you (right click and 'Save As'):

    index.html.txt

    Once you have it, rename it to index.html and replace your current page with it.

    The browser cache may need to be cleared and/or the page refreshed to see changes.
    Last edited by jscheuer1; 05-15-2013 at 01:10 PM. Reason: improve attachment
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Similar Threads

  1. Shockwave 3D slideshow v0.9
    By sxicion in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 05-09-2013, 04:28 AM
  2. Shockwave 3D Slideshow does not work with IE
    By dogsmommy in forum Bug reports
    Replies: 3
    Last Post: 01-10-2013, 06:13 AM
  3. Shockwave 3D slideshow v0.9
    By Matthew Race in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 09-18-2012, 06:30 AM
  4. Sequence Images in Shockwave Slideshow
    By bfchris in forum Dynamic Drive scripts help
    Replies: 6
    Last Post: 08-15-2012, 02:52 AM
  5. HV Menu with Shockwave problem
    By Sossy in forum JavaScript
    Replies: 3
    Last Post: 01-30-2005, 06:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •