Results 1 to 3 of 3

Thread: Brother Cake's Top Navigational Bar disappears in IE10

  1. #1
    Join Date
    Mar 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Brother Cake's Top Navigational Bar disappears in IE10

    1) Script Title: Top Navigational Bar III v3.5 (By BrotherCake

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...men3/index.htm

    3) Describe problem: I have been using this menu script from Dynamic Drive for some years now without problem. Then my Internet Explorer updated to v10 and it suddenly no longer work. It 's still fine in IE9 and below, and in Chrome, Firefox and Safari, but in IE10 the menu does not appear at all and, even more mysteriously, the simple HTML text links I put in "behind" it for just this kind of eventuality has also disappeared. This happens on my hard drive as well as online. The website is at http://www.argumentsforatheism.com/, and the menu should appear just below the logo banner.
    I don't know enough about what has changed in IE10 to know what might be the issue. Doctype maybe? This script seems to work fine in the other browsers (and in IE earlier than 10), so long as I don't use any doctype at all, otherwise it messes up the alignment, etc. Or might anything need doping with the subsidiary js files for this particular browser?

  2. #2
    Join Date
    Aug 2004
    Posts
    9,911
    Thanks
    3
    Thanked 969 Times in 957 Posts
    Blog Entries
    15

    Default

    Hi:
    Firstly, it's important to note that Brothercake Menu is a very old script; there are quite a few alternatives on DD that have a much wider range of compatibility, especially when it comes to the more recent browsers. A few of them are: DD Smooth Menu and DD Mega Menu.

    Regarding your specific issue then, using IE10, the menu actually appears to function correctly for me. Are you using a Preview release of IE10, or official? The machine specs I'm using is Win 7, IE v10.09
    DD Admin

  3. #3
    Join Date
    Mar 2013
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Well, that's weird. I'm using Win 7, IE v10.09 as well. The only way I've been able to make it work it by dumbing the whole page down and making IE10 think it's not IE10 at all, using <meta http-equiv="X-UA-Compatible" content="IE=5">
    I did speak to Brother Cake about it, and he was not interested in the problem and was generally very dismissive about it.
    Anyway, that solution will suffice for those those sites, and I just won't use it again!
    Thanks you your interest.
    Luke

Similar Threads

  1. CSS 3D Flip doesn't work in IE10!
    By loljez in forum Dynamic Drive scripts help
    Replies: 11
    Last Post: 01-27-2013, 07:28 PM
  2. Replies: 0
    Last Post: 12-02-2011, 02:56 PM
  3. JXtension - JQuery's Little Brother
    By bardonw in forum JavaScript
    Replies: 0
    Last Post: 12-02-2009, 06:11 PM
  4. Navigation bar III disappears
    By devjoy in forum Dynamic Drive scripts help
    Replies: 0
    Last Post: 08-14-2005, 02:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •