Results 1 to 3 of 3

Thread: HTML is Broken

  1. #1
    Join Date
    Oct 2012
    Posts
    66
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default HTML is Broken

    So well testing my page I noticed that some of the elements look like they are all in the same DIV. I went through it, but I'm pretty sure all my DIVs have the proper ending.

    See the page here: http://zanime.net/test/

    CSS: http://zanime.net/test/css/style.css

    The page should look like the first 2 boxes.

    EDIT

    Well testing it locally I pinpointed the problem to this code:

    HTML Code:
    <div class="tb-container"><!-- ENGINE001 start .TB-CONTAINER -->
    <div class="tb-header">
    <span>Engine001</span>
    <span class="tb-header-os">Operating System:
     <img class="windows" src="images/windows-logo-icon.png" alt="Windows">
    </span>
    </div><!-- end .tb-header -->
    
    <img class="gd-image" src="images/gd-img/engine011.jpg" alt=""/>
    
    <p class="tb-descripter">
    The graphical scripter within 001 Game Creator is a simple, yet powerful method of creating events for your game without the difficulty of learning to write code. It uses the simplicity of pointing and clicking to allow the user to easily implement events in the form of a flowchart...(<a href="http://www.engine001.com/features.htm" target="_blank">Read More</a>)
    </p>
    <div class="tb-footer">
     <span class="tb-footer-type"><span class="2d">2D</span></span>
     <span class="tb-footer-price"><span class="free" class="commercial">Free/Commercial</span></span>
    </div><!-- end .tbfooter -->
    </div><!-- ENGINE001 end .TB-CONTAINER -->
    If I add an extra DIV end tag it slightly fixes the issue, but then that entire DIV ends up slightly broken broken. See what I mean here: http://zanime.net/test/index2.html

    The GAP at the top of Engine001 should not be there.
    ~Kage
    Last edited by Kage Kazumi; 10-16-2012 at 04:30 AM.

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,926
    Thanks
    43
    Thanked 3,192 Times in 3,155 Posts
    Blog Entries
    12

    Default

    First try validating the HTML code:

    http://validator.w3.org/check?verbos....net%2Ftest%2F
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Oct 2012
    Posts
    66
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you. Found the extra DIV and a few other errors. Bookmarked.

Similar Threads

  1. Tabs broken in IE8
    By mimib in forum Dynamic Drive scripts help
    Replies: 1
    Last Post: 07-31-2009, 07:02 PM
  2. My JavaScript is broken.
    By techno_race in forum JavaScript
    Replies: 12
    Last Post: 08-22-2008, 10:59 PM
  3. Broken Cymbals...
    By Rockonmetal in forum Picture Gallery
    Replies: 4
    Last Post: 11-20-2007, 08:58 PM
  4. mouseWheelEnabled 'Broken'
    By tomyknoker in forum Flash
    Replies: 0
    Last Post: 03-27-2007, 06:10 PM
  5. Broken Images
    By maverick in forum JavaScript
    Replies: 5
    Last Post: 09-16-2005, 10:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •