Results 1 to 3 of 3

Thread: link in slideshow doesn't work

  1. #1
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default link in slideshow doesn't work

    1) Script Title: Fade in Slideshow

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

    3) Describe problem:
    I added links to some of the images in the slideshow and it does not work.
    I have different slideshow on our website and when adding links to them it works - we get the hand and it is clickable
    On a certain one it used to work and now it doesn't
    I looked carefully what has changed but cannot see the problem and need your help:
    Link to the page http://wcce.ajula.edu/courselist.aspx
    The js library iink Scripts/fadeslideshow.2-4.js
    the script file that hold the creation of the slideshow http://wcce.ajula.edu/Scripts/InternalSlideshowWCCE.js
    Here is its content:
    // JavaScript Document


    var mygallery=new fadeSlideShow({
    wrapperid: "photoHeaderSlideshow", //ID of blank DIV on page to house Slideshow
    dimensions: [953, 231], //width/height of gallery in pixels. Should reflect dimensions of largest image
    imagearray: [
    ["../Images/wcceImages/internalSlidShow/40-Hours-to-Decide-231.jpg", "http://wcce.ajula.edu/forms/frwcce40.aspx", "", ""],
    ["../Images/wcceImages/internalSlidShow/real_housewives_bible.jpg", "http://www.ajula.edu/housewives", "", ""],
    ["../Images/wcceImages/internalSlidShow/Hanukkah-Family-FunDay.png", "", "", ""],
    ["../Images/wcceImages/internalSlidShow/ARCHAEOLOGY_2013.jpg", "", "", ""] //<--no trailing comma after very last image element!
    ],
    displaymode: {type:'auto', pause:5000, cycles:0, wraparound:false},
    persist: false, //remember last viewed slide and recall within same session?
    fadeduration: 3000, //transition duration (milliseconds)
    descreveal: "ondemand",
    togglerid: ""
    })

    Please help
    Thanks
    myalo

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    The slideshow is covered by the messagesOnPicture div element. Set its display to none, and the links will work. This div is mentioned numerous times in the stylesheet. Here's one of the many places you could add that style - wcce.ajula.edu/Styles/custom_WCCE.css around line 74, addition highlighted:

    Code:
    .interior #messagesOnPicture {   /* Used in this subsite to display the subsite logo over the slideshow. */
    	height: 231px;
    	display: none;
    /*	background-image: url(../images/wcceImages/subsiteLogo_interior.jpg); */
    
    }
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by jscheuer1 View Post
    The slideshow is covered by the messagesOnPicture div element. Set its display to none, and the links will work. This div is mentioned numerous times in the stylesheet. Here's one of the many places you could add that style - wcce.ajula.edu/Styles/custom_WCCE.css around line 74, addition highlighted:

    Code:
    .interior #messagesOnPicture {   /* Used in this subsite to display the subsite logo over the slideshow. */
    	height: 231px;
    	display: none;
    /*	background-image: url(../images/wcceImages/subsiteLogo_interior.jpg); */
    
    }
    Thanks this was it.
    The idea was to have the possible to lay on top of the picture / slideshow a message or logo. By mistake I made it as big as the slideshow. Now I specified much shorter height and the <a> works
    Again thanks for helping me
    myalo

Similar Threads

  1. will this work with an internal link
    By ajfmrf in forum JavaScript
    Replies: 4
    Last Post: 05-18-2012, 11:51 AM
  2. Ultimate Fade-in Slideshow - wont work on-line but will work off-line
    By southerncrow in forum Dynamic Drive scripts help
    Replies: 6
    Last Post: 12-21-2010, 02:27 PM
  3. Replies: 19
    Last Post: 10-09-2010, 06:10 AM
  4. a:link rule won't work on a link tag
    By mdisch in forum CSS
    Replies: 8
    Last Post: 08-27-2008, 07:27 PM
  5. Anylink CCS top link doesn't work
    By jimboud in forum Dynamic Drive scripts help
    Replies: 2
    Last Post: 02-10-2006, 08:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •