Results 1 to 5 of 5

Thread: Connect database from other localhost

  1. #1
    Join Date
    Nov 2010
    Posts
    114
    Thanks
    27
    Thanked 0 Times in 0 Posts

    Default Connect database from other localhost

    Hi All,

    Can anyone tell how to connect to database in different server. Now if i want in Localhost i will give

    Host = Localhost
    username = abcdef
    password = abcdef

    But if i want to connect for another database in different ip

    Host = 192.168.1.14
    username = abcdef
    password = abcdef


    The above configuration is not working. I am using Ubuntu OS, can anyone help me in this.

  2. #2
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,162
    Thanks
    263
    Thanked 690 Times in 678 Posts

    Default

    In theory, that's fine. The problem is in the details, I think.

    Of course you should be sure that the remote server allows external connections. That could be disabled. If so, you need to enable it.
    Daniel - Freelance Web Design | <?php?> | <html>| espa˝ol | Deutsch | italiano | portuguŕs | catalÓ | un peu de franšais | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  3. #3
    Join Date
    Nov 2010
    Posts
    114
    Thanks
    27
    Thanked 0 Times in 0 Posts

    Default

    where can i enable those settings?

  4. #4
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,162
    Thanks
    263
    Thanked 690 Times in 678 Posts

    Default

    In the MySQL configuration on the server running the database. It might depend on how you're managing it.
    Daniel - Freelance Web Design | <?php?> | <html>| espa˝ol | Deutsch | italiano | portuguŕs | catalÓ | un peu de franšais | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  5. The Following User Says Thank You to djr33 For This Useful Post:

    hemi519 (04-20-2012)

  6. #5
    Join Date
    Nov 2010
    Posts
    114
    Thanks
    27
    Thanked 0 Times in 0 Posts

    Default

    Thanks, I got it working

    In /etc/mysql/my.conf look for this line:

    bind-address = 127.0.0.1

    change it to

    #bind-address = 127.0.0.1

    now restart /etc/init.d/mysql restart

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •