Results 1 to 3 of 3

Thread: Ultimate Fade-in slide show v2.4 not showing in up IE, Opera, or Safari

  1. #1
    Join Date
    Mar 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation Ultimate Fade-in slide show v2.4 not showing in up IE, Opera, or Safari

    1) Script Title: Ultimate Fade-in slide show v2.4

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

    3) Describe problem:
    The problem i am having is this worked perfectly fine on friday and this morning it is not working in IE, Opera, or Safari

    It works great in firefox and chrome

    I have been trying to debug all morning and haven't figured it out

    Someone Please help


    here is my link
    http://www.staging.impressionsmedia.biz/

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,134
    Thanks
    44
    Thanked 3,231 Times in 3,192 Posts
    Blog Entries
    12

    Default

    You've hacked up that script a bit trying to get it to do what you want, eh? As a result you have a not too cross browser version.

    This seems to work -

    1. Revert to the original version of the script.

    2. Put this stylesheet in the head of the page:

      Code:
      <style type="text/css">
      #fadeshow1, #fadeshow2, #fadeshow3, .gallerylayer {
      	background: transparent !important;
      }
      </style>
    3. Get rid of all of the blank entries in the imagearray arrays, or use a transparent .gif image for each of them. Example, if you keep them:

      Code:
      	imagearray: [
      		["blank.gif", "" ],
      		["http://staging.impressionsmedia.biz/test/slideshow/1.jpg", "http://staging.impressionsmedia.biz/test/slideshow/1-large.jpg" ],
      		["blank.gif", "" ],
      		["http://stagin . . .
    4. Add this declaration once at the beginning of the script where you declare the slideshows on the page (addition highlighted):

      Code:
      <script type="text/javascript">
      fadeSlideShow.gals = 0;
      var mygallery=new fadeSlideShow({
      	wrapperid: "fadeshow1", //ID of blank DIV on page to house Slideshow
      	dimensions: [490, 214], //width/height of gallery in pixels. Should reflect dimensions of largest image
      	imagearray: [
      		["http://stagi . . .
    5. Add this at the end of each new FadeSlideShow declaration, example:

      Code:
       . . . ressionsmedia.biz/test/slideshow/10.jpg", ""]
      	],
      	displaymode: {type:'auto', pause:1030, cycles:0, wraparound:false},
      	persist: false, //remember last viewed slide and recall within same session?
      	fadeduration: 500, //transition duration (milliseconds)
      	descreveal: "ondemand",
      	togglerid: "",
      	oninit: function(){
      		if(++fadeSlideShow.gals === 3){
      			jQuery('.gallerylayer a').attr('rel', 'lightbox');
      		}
      	}
      })
      Don't miss the added comma (red) after the togglerid value.


    The browser cache may need to be cleared and/or the page refreshed to see changes.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Mar 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you so much.

    That worked great for those 3 browsers but now i am getting a weird black ghosting effect in firefox on the PC

    it isn't doing it on firefox on the mac

    and it's only firefox

    when i set the background to white on the fadeshow.js

    I get overlap of my images but when you set it to none or transparent i get the black blinking in firefox

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •