Results 1 to 3 of 3

Thread: browser blocking my scripts

  1. #1
    Join Date
    Jun 2008
    Posts
    107
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Default browser blocking my scripts

    I have a webpage that you can view here: http://www.shahspace.com/bow/home.html. I'm running IE9 and when I load this page it tells me:

    "Internet Explorer restricted this webpage from running scripts or ActiveX controls"

    The restriction of running scripts seems to be disabling the drop down menus from showing up. This may or may not happen for you. If it doesn't, you should be able to click on either of the menu items "services", "information", or "health & safety" and see a drop down menu show up. If your browser is blocking scripts just as mine is, you may have to click on "allow blocked content" before these drop down menus show up.

    I don't want the user to have to do this. I would like to know if there's anything I can implement into the webpage itself so that the user's browser doesn't automatically block the running of scripts?

  2. #2
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,164
    Thanks
    265
    Thanked 690 Times in 678 Posts

    Default

    IE blocks things depending on your security settings. I don't know the details in this case, but my guess is that nothing is wrong with your script. Change your security settings, and your users will be able to use it if they have security settings that allow it. It's that simple.

    There's also an issue with IE when testing locally. But since this is online, I don't think that's the problem. In that case, it is just that it's blocking locally running scripts, but won't do the same thing for scripts on a live site. So I think the problem here is unrelated to that.
    Daniel - Freelance Web Design | <?php?> | <html>| espa˝ol | Deutsch | italiano | portuguŕs | catalÓ | un peu de franšais | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  3. #3
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,167
    Thanks
    44
    Thanked 3,240 Times in 3,201 Posts
    Blog Entries
    12

    Default

    Works fine in IE 9 here.

    Perhaps you were a little confused and were testing a local copy of it. That would do it.

    Otherwise, your security settings in IE 9 might be higher than the defaults.

    In IE 9 choose:

    Tools > Internet Options > Security

    See if the word 'Internet' under the globe of the Earth icon is highlighted. If not, you are not viewing the live page over the internet.

    If it is, then make sure that security for the Internet is set to the default level.

    If all that's good and you still have a problem, check the Advanced tab. Make sure that's set to the defaults.

    Other than that, I can't think of anything else that could be causing it except maybe a third party program or Network settings, like if your IE 9 is on a Network at school or at work where the admin has disabled certain settings.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •