Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Bornegraphics is LIVE!!!!!

  1. #1
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    22
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Default Bornegraphics is LIVE!!!!!

    Fellow DynamicForum users,

    Let me start of by saying what a great forum this is. I have posted several questions and problems here all of which have been answered. I thank you all for taking the time to help a fellow designer out. Your help has been greatly appreciated and has helped me launch my website.

    I invite you all to check out the final product. I am continuously adding content and I do welcome and would appreciate any and all feedback.

    www.bornegraphics.com

    Best regards,
    Alan

  2. #2
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,164
    Thanks
    265
    Thanked 690 Times in 678 Posts

    Default

    The images on your portfolio page loaded very slowly. Did you do that intentionally so that all of them were preloaded? The initial delay is more problematic than waiting a few seconds each time you click "next", I think.

    Generally, looks good. I prefer minimal sites (like this one), and the design seems effective. One missing component is any explanation of what the site is or what it is for on the main page. If someone accidentally finds your site, it would be good to have a sentence or two explaining why they should take a look around.
    Daniel - Freelance Web Design | <?php?> | <html>| español | Deutsch | italiano | português | català | un peu de français | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  3. The Following User Says Thank You to djr33 For This Useful Post:

    bornegraphics (02-21-2012)

  4. #3
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    22
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Default

    djr33,

    I want to thank you for taking the time to visit my site, your feedback is greatly appreciated. With regards to the portfolio images, at second glance I did see that some of the images are between 100-200kb, which by the sounds of it are way too large and need to be optimized. What is the recommend file size for images like I use, any suggestions?

    You make a valid point about an explanation of what my site does or is used for. Very smart, thanks for suggesting it.

    Thanks again,
    Alan

  5. #4
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,164
    Thanks
    265
    Thanked 690 Times in 678 Posts

    Default

    100-200kb isn't too bad for portfolio images, especially when you don't want to make them look bad (since you're demonstrating how good they look).

    But they shouldn't take that long to load.

    Here's a more complete description of what happened:
    1. I clicked the link to your portfolio page.
    2. For about 20-30 seconds, the first image VERY slowly (line by line) loaded on the page.
    3. After the image was fully loaded, then I clicked the "next" arrow.
    4. Each new image loaded instantaneously.

    Is there a reason that first image should be delayed? I have a fast connection and images don't usually take that long to load. I wouldn't mind a 1-3 second delay (which is all that 100kb should take), but the 20-30 seconds was weird.

    Note: it's not happening again. But the images are probably cached in my browser.

    This might be due to your server, but I'm not sure. I also notice that there's now a "moon" image on the homepage, and that wasn't there before-- probably delayed loading too. Checking your site from a few computers to be sure everything loads consistently might help. If not, maybe look into getting a new host. There are lots of cheap hosts, so don't limit yourself to one that isn't loading quickly.
    Daniel - Freelance Web Design | <?php?> | <html>| español | Deutsch | italiano | português | català | un peu de français | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  6. The Following User Says Thank You to djr33 For This Useful Post:

    bornegraphics (02-21-2012)

  7. #5
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    22
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Default

    That is weird the it took 20-30secs to load. I've check on a few computers that I have and it takes maybe 5-10secs if that. There is no reason why the first image should take so long to load. Like you I would prefer the image to load right away, maybe 5secs max but definitely no more than that.

    I think I will try and reduce the file size first and see what happens after that. The only other thing I can think of that might cause the delay, is the type of slideshow script I am using. Do you think that could cause the delayed loading time?

    I am currently using GoDaddy as my host, are they good to use or should I which to a definitely host/server provider?

  8. #6
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,164
    Thanks
    265
    Thanked 690 Times in 678 Posts

    Default

    Well, I'm just remembering what happened. It might have been 10 seconds. But remember than in "web browsing time" that's still a lot-- users tend to make a decision about liking a page within 1-3 seconds (I've heard this cited in a wide range, but something close to that is reasonable).
    I don't see why the first image would take longer than the others either-- that's why I asked if you have a preloader script (loading all images slowly, then they're all preloaded and show up instantly when you click "next").
    Daniel - Freelance Web Design | <?php?> | <html>| español | Deutsch | italiano | português | català | un peu de français | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  9. The Following User Says Thank You to djr33 For This Useful Post:

    bornegraphics (02-21-2012)

  10. #7
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    22
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Default

    Mind having a look at the initial page that is viewed when you click on portfolio. Perhaps you are seeing something in the code that I am not.

    Zipped file attached.

  11. #8
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    22
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Default

    djr33,

    any chance you could have a look at the initial portfolio page now and see if you still have the long load time. I might have found a 'preload' image code that I removed.

    Did this help?

    I still plan on revising the image sizes which I think will help the load time as well.

    Cheers,

    Alan

  12. #9
    Join Date
    Mar 2006
    Location
    Illinois, USA
    Posts
    12,164
    Thanks
    265
    Thanked 690 Times in 678 Posts

    Default

    I wasn't looking at the code. It's going to depend on your server, so I'd need to see a live page (you can use a new filename that isn't linked if you don't want it to be seen by visitors). If I look at it on my computer, it will load instantaneously (because there's no transfer time from my computer to my computer).
    Daniel - Freelance Web Design | <?php?> | <html>| español | Deutsch | italiano | português | català | un peu de français | some knowledge of several other languages: I can sometimes help translate here on DD | Linguistics Forum

  13. #10
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    22
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Default

    If you re-visit the portfolio section of bornegraphics.com and view the web development page I remove what seemed to be a preloader code. Does it load any faster?

    What about the homepage graphic, does the moon image load faster. I reduced the file size.

    I also reduced the file size of some of the identity and digital artwork portfolio pieces. Perhaps if and when you have time you could view those pages and see how fast or slow they load.

    Thanks again for all your help.

    Cheers,
    Alan

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •