Results 1 to 3 of 3

Thread: simple controls gallery 1.4 on IE 8

  1. #1
    Join Date
    Jan 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default simple controls gallery 1.4 on IE 8

    1) Script Title: Simple Controls Gallery 1.4

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...plegallery.htm

    3) Describe problem: I have incorporated this script on the index page of one my sites -- www.integritytransportservices.com -- however the images don't display in IE 8. I get a script error -- 'imagearray[...].0' is null or not an object
    Line: 43
    Char: 3
    Code: 0
    URI: http://www.integritytransportservice...mplegallery.js

    The images display fine in IE 9, FF, and chrome. Any ideas?

    Thanks!

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    No comma (red) allowed after the last imagearray item (highlighted):

    Code:
    <script type="text/javascript">
    
    var mygallery=new simpleGallery({
    	wrapperid: "simplegallery1", //ID of main gallery container,
    	dimensions: [379, 330], //width/height of gallery in pixels. Should reflect dimensions of the images exactly
    	imagearray: [
    		["http://www.integritytransportservices.com/images/cars.jpg", "", "", ""],
    		["http://www.integritytransportservices.com/images/car-driver1.jpg", "", "", ""],
    		["http://www.integritytransportservices.com/images/suburban_ext.jpg", "", "", ""],
    		["http://www.integritytransportservices.com/images/suburban_seat.jpg", "", "", ""],
    		["http://www.integritytransportservices.com/images/suburban_int.jpg", "", "", ""],
    		["http://www.integritytransportservices.com/images/suburban_lts.jpg", "", "", ""],
    		],
    	autoplay: [true, 2500, 2], //[auto_play_boolean, delay_btw_slide_millisec, cycles_before_stopping_int]
    	persist: false, //remember last viewed slide and recall within same session?
    	fadeduration: 500, //transition duration (milliseconds)
    	oninit:function(){ //event that fires when gallery has initialized/ ready to run
    		//Keyword "this": references current gallery instance (ie: try this.navigate("play/pause"))
    	},
    	onslide:function(curslide, i){ //event that fires after each slide is shown
    		//Keyword "this": references current gallery instance
    		//curslide: returns DOM reference to current slide's DIV (ie: try alert(curslide.innerHTML)
    		//i: integer reflecting current image within collection being shown (0=1st image, 1=2nd etc)
    	}
    })
    
    </script>
    That's strict javascript rules. All browsers except IE 8 and less will now error correct that for you. Remove that comma and it should be fine.

    The browser cache may need to be cleared and/or the page refreshed to see changes.
    Last edited by jscheuer1; 01-18-2012 at 02:07 AM. Reason: typo in the text portion of the post
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Jan 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Red face

    Thanks for your help -- that solved the problem and the page now displays properly !!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •