Results 1 to 4 of 4

Thread: Thumbnailer II question ...

  1. #1
    Join Date
    Dec 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cool Thumbnailer II question ...

    Script: Thumbnailer II

    http://www.dynamicdrive.com/dynamici...thumbnail2.htm

    Good evening folks ...

    I haven't posted here before, and I'm sorry to start with a question, but I wonder if any of the resident experts could help with a problem I've been struggling with for a couple of days now.

    I have used the above script to create a gallery page(s) on my website, and I've managed to figure out - with a couple of pointers from a friend - how to modify the script to get it to run on a 'Frames' page. But I have a remaining issue that I just can't figure out ...

    An example of my implementation of the script is here -

    Gallery page

    I can get the fullsize image to open in the right-hand frame correctly, but if a viewer clicks on a thuimbnail rather than just hovering the mouse over the thumb, the thumbnails appear in the main frame.

    I'm no HTML or JavaScript expert (far from it!), but I've tried and tried, and searched for help here and elsewhere on the web, but I just can't figure it out. Hence my plea for assistance.

    Can this problem be sorted, or have I wasted my efforts in getting this far?

    I've attached two text documents that include the code used for each frame, so anyone who cares to assist can see the modifications that I've made.

    Any help would be greatly appreciated

  2. #2
    Join Date
    Jun 2005
    Location
    英国
    Posts
    11,876
    Thanks
    1
    Thanked 180 Times in 172 Posts
    Blog Entries
    2

    Default

    Code:
    <a href="#" onMouseover="modifyimage('dynloadarea', 4)"><img border="0" src="Images/landscape/landscape5th.jpg" width="100" height="67"></a>&nbsp;&nbsp;
    I don't understand why you've used links. Put the onmouseover event into the image directly:
    Code:
    <img onmouseover="modifyimage('dynloadarea', 4)" border="0" src="Images/landscape/landscape5th.jpg" width="100" height="67">&nbsp;&nbsp;
    Twey | I understand English | 日本語が分かります | mi jimpe fi le jbobau | mi esperanton komprenas | je comprends franšais | entiendo espa˝ol | t˘i Ýt hiểu tiếng Việt | ich verstehe ein bisschen Deutsch | beware XHTML | common coding mistakes | tutorials | various stuff | argh PHP!

  3. #3
    Join Date
    Dec 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks Twey.

    I tried removing the Hyperlinks, because I could see that was the source of the problem, but I made a complete hash of it.

    Now that I see how I SHOULD have done it, I'm more than a little embarassed ...

    Thank you again, your help is appreciated. It all works as it should now. I'll finish off tidying up the pages on Monday. Beer call in the pub tonight ...

    Have a good weekend!

  4. #4
    Join Date
    Jun 2005
    Location
    英国
    Posts
    11,876
    Thanks
    1
    Thanked 180 Times in 172 Posts
    Blog Entries
    2

    Default

    It's always so obvious once you work it out

    Enjoy your own.
    Twey | I understand English | 日本語が分かります | mi jimpe fi le jbobau | mi esperanton komprenas | je comprends franšais | entiendo espa˝ol | t˘i Ýt hiểu tiếng Việt | ich verstehe ein bisschen Deutsch | beware XHTML | common coding mistakes | tutorials | various stuff | argh PHP!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •