Advanced Search

Results 1 to 4 of 4

Thread: Image thumbnail viewer ii - works in preview but not on net

  1. #1
    Join Date
    Nov 2006
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Image thumbnail viewer ii - works in preview but not on net

    Hi,

    I have had a go at using the Image Thumbnail Viewer II. I can get it to work on my PC when I view it (in Dreamweaver) however once uploaded it does not work. If you are fast enough to click on the image when the page is still loading you will be taken off to a blank page for viewing the image however it is not loading on the actual page where the thumbnail is.

    Note I have uploaded the "thumbnailviewer.css/.js as well as the loading.gif to my host.

    The link to the webpage concerned is: http://artilleryhistory.org/gun_regi...land_test.html .

    Any help would be greatlyt appreciated to advise where I have gone wrong !

    Kind regard & many thanks,

    Graham

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,690
    Thanks
    43
    Thanked 3,129 Times in 3,095 Posts
    Blog Entries
    12

    Default

    If I navigate directly to /gun_register/norfolk_island/photos_norfolk_island/gun_norfolk_Island_18pdr.jpg, it comes up. But on the page (once one has clicked on the thumbnail) it's a broken image icon. I've seen this once before. In that case it was I believe a problem with permissions on the image file and/or its folder.

    That's set server side, either in a .htaccess file or the server configuration.

    There is a typo (red in the highlighted section - scroll the code block to see it):

    Code:
    <a href="http://www.artilleryhistory.org.au/gun_register/norfolk_island/photos_norfolk_island/gun_norfolk_Island_18pdr.jpg"" rel="thumbnail"><img src="photos_norfolk_island/gun_norfolk_Island_18pdr.jpg" style="width: 250px; height: 180px" /></a>
    But removing that extra quote mark didn't seem to help.
    Last edited by jscheuer1; 11-02-2011 at 07:08 AM. Reason: add - There is a typo . . .
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Nov 2006
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Script help

    Hi John,

    Thanks for taking the time to have a look at this for me. I have corrected the typing error by removing the " however as you say it did not help.

    I will keep working at it, but I do sincerely appreciate you taking the time to have a look at it for me and making the effort to respond.

    Take care and thanks again,

    Regards,

    Graham

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,690
    Thanks
    43
    Thanked 3,129 Times in 3,095 Posts
    Blog Entries
    12

    Default

    Quote Originally Posted by jscheuer1 View Post
    I've seen this once before. In that case it was I believe a problem with permissions on the image file and/or its folder.

    That's set server side, either in a .htaccess file or the server configuration.
    This probably deserves more explanation. Permissions can also be set in most ftp programs using chmod or the ftp program's equivalent. The chmod command is also available in various terminal type interfaces, but those are rarely used these days. If all else fails, check your host's faq. It probably has something on setting permissions for files and folders. If not, or if you have trouble understanding it, contact your host's support.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •