Results 1 to 4 of 4

Thread: jQuery Image Magnify Hiding under a video

  1. #1
    Join Date
    Oct 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default jQuery Image Magnify Hiding under a video

    1) Script Title: jQuery Image Magnify v1.11

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...agemagnify.htm

    3) Describe problem: When first installed it worked great. Since then, an embedded video has been added to the web site. Now, the image to be magnified opens under the video. Looks to be a style problem but am not able to fix it. Any help would be appreciated.

    Here is the web site: http://www.bvgasa.org/index.aspx

    The magnify image is the Photo of the Week on the top of the 3rd column.

    Thanks very much.

  2. #2
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    For Adobe Flash bleeding through, you might want to try the suggestion described here, which is to add:

    Code:
    wmode="transparent"
    inside your Flash object.
    DD Admin

  3. #3
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    Using wmode opaque is sometimes better. But you can use transparent. Sometimes it washes out the background of the Flash. And you need to add what ddadmin shows in his code to the embed, not the object. While the object needs a parameter added to it. More specifically, using your existing Flash tags (additions highlighted):

    Code:
    <object id="flashObj" width="486" height="412" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,47,0">
    <param name="movie" value="http://c.brightcove.com/services/viewer/federated_f9?isVid=1" />
    <param name="bgcolor" value="#FFFFFF" /><param name="flashVars" value="videoId=926353529&
    playerID=44978634001&playerKey=AQ~~,AAAAACVjNrc~,Iy6qZmjC76PO3emQNxASBnJy0caINoyj&domain=
    embed&dynamicStreaming=true" /><param name="base" value="http://admin.brightcove.com" />
    <param name="wmode" value="opaque" />
    <param name="seamlesstabbing" value="false" /><param name="allowFullScreen" value="true" />
    <param name="swLiveConnect" value="true" /><param name="allowScriptAccess" value="always" />
    <embed src="http://c.brightcove.com/services/viewer/federated_f9?isVid=1" 
    bgcolor="#FFFFFF" flashVars="videoId=926353529&playerID=44978634001&playerKey=AQ~~,
    AAAAACVjNrc~,Iy6qZmjC76PO3emQNxASBnJy0caINoyj&domain=embed&dynamicStreaming=true" 
    base="http://admin.brightcove.com" name="flashObj" width="486" height="412" seamlesstabbing="false" 
    type="application/x-shockwave-flash" wmode="opaque" allowFullScreen="true" swLiveConnect="true" 
    allowScriptAccess="always" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?
    P1_Prod_Version=ShockwaveFlash"></embed></object>
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  4. #4
    Join Date
    Oct 2011
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thumbs up

    Once again, your solution works the first time!

    Thanks very much. I went with the opaque setting. Beautiful job.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •