Results 1 to 3 of 3

Thread: SWF Files playing simultaneously after rolling over images

  1. #1
    Join Date
    Feb 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation SWF Files playing simultaneously after rolling over images

    1) Script Title: Featured Content Slider v2.4

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...tentslider.htm

    3) Describe problem: The problem with this script is only visible in IE8. I have four images that you can rollover to bring up their respective swf file. When I scroll over one it'll play but when I scroll over another image it won't stop playing the first swf and you end up with the sound overlapping. I've tried to use the onChange event handler but it still didn't solve anything. If the onChange event handler is the solution to this problem what must be inserted in the parentheses after the videoplayer.stop command?

    Ex. (videoplayer.stop("whatgoesinhere")

    I'd really appreciate the feedback. Thanks!

  2. #2
    Join Date
    Aug 2004
    Posts
    9,918
    Thanks
    3
    Thanked 969 Times in 957 Posts
    Blog Entries
    15

    Default

    You sort of answered the question already. What exactly to call inside the onChange event handler of the script is entirely dependent on the video player you're using and what's available to it to stop and play videos dynamically. The code:
    Code:
    videoplayer.stop("whatgoesinhere")
    is just an example; it could very well be something completely different, such as:

    Code:
    myvideo.command('stop')
    What that command is you'll need to check the documentation of the video player you're using...
    DD Admin

  3. #3
    Join Date
    Feb 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation

    Ok I've tried a few different things with the code and it still doesn't work. I went through the adobe flash player documentation and didn't find any specific piece of code that stops the SWF.

    Let me reiterate that this problem is only occurring in Internet Explorer 8. You can view the page at http://www.graphixdesignz.com/animation/animation.html

    I would like to assume that this is an IE 8 glitch with the script but I'm sure there's a work around to get it working correctly. I look forward to your feedback!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •