Results 1 to 6 of 6

Thread: Alignment in Safari

  1. #1
    Join Date
    Dec 2008
    Posts
    15
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Default Alignment in Safari

    1) Script Title: AnyLink Drop Down

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...pmenuindex.htm

    3) Describe problem:


    Hi All,

    When viewed in Firefox on a Mac, the drop down menu works perfectly. I am having a problem with my navigation when viewed in Safari on a Mac. I am not sure about how things function on a PC.

    When viewed in Safari, the drop down menu appears unaligned with the buttons it corresponds to. For example, on the following page http://www.oharenoise.org/new/mission.htm when you mouseover "About Us" the corresponding menu shows up under "Home."

    The other problem (only in Safari, as far as I know) I am having occurs on the homepage, viewed here. When you mouseover "About Us", "Newsroom", "Residential", "School" or "Technical" the drop-down menu appears in front of the Flash slideshow perfectly, until the slide changes pictures and then the menu falls behind the slide.

    Any idea why either of these issues are occurring?

  2. #2
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    Try moving the onMouseover/out events within each link from the A tag into the IMG tag instead, for example:

    Code:
    <a href="about_us.htm" onClick="return clickreturnvalue()" ><img src="images/navigation/new/about.jpg" width="91" height="35" border="0" onMouseover="dropdownmenu(this, event, menu1, '170px')" onMouseout="delayhidemenu()" /></a>
    I don't have a Mac to confirm whether this works, but worth a shot.
    DD Admin

  3. #3
    Join Date
    Dec 2008
    Posts
    15
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Default

    Thanks for replying. Unfortunately, that did not resolve the problem.

    The homepage code is the same (I've copy & pasted it on all other pages). My guess is that this is a CSS problem because the homepage has a different style sheet than the rest of the site but I can't seem to figure out what the difference is.

    Any other ideas?

    The homepage CSS is here

    And the other CSS is here

  4. #4
    Join Date
    Jan 2011
    Posts
    50
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    i've tried checking thew website you gave and opened it using chrome in windows xp...the about us part is not under home but before it... way out of the whole margin of the page and so are the rest of the drop downs.... but i don't know if the screen resolution affects it too..have you tried checking it?

  5. #5
    Join Date
    Dec 2008
    Posts
    15
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Default

    Yes, screen resolution does not effect this script. I used the exact script on another website (see here) and don't have this problem.

    In fact, I didn't have this problem in earlier versions of this website. So I know it is something I did in the process but I can't seem to find out what.

    Thank you for all the suggestions. I am truly lost.

  6. #6
    Join Date
    Jan 2011
    Posts
    50
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    try to review the script again...i'm guessing it's just a little error...coz if it really does not work, then it won't work on other websites...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •