Results 1 to 6 of 6

Thread: Simple Controls Gallery v1.3 Not Displaying

  1. #1
    Join Date
    Mar 2009
    Posts
    8
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Default Simple Controls Gallery v1.3 Not Displaying

    1) Script Title: Simple Controls Gallery v1.3

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...plegallery.htm

    3) Describe problem:

    I seem to be having a problem getting the gallery to display on my page. This is not an issue with the comma since it's not showing up in IE or Firefox. It was working a while back and I've probably messed it up somehow since then, but I don't know what I did wrong! Everything looks fine to me and I haven't changed anything in the code or js files.

    I have a mouse-over script from Javascript Source on the same page as well. Could there be some sort of conflict?

    Website is located here: http://www.chaoticexotics.ca/

    The gallery should be coming up right below the buttons. Here's my code:

    Code:
    </script>
     
    <script type="text/javascript">
     
    var mygallery=new simpleGallery({
    	wrapperid: "simplegallery1", //ID of main gallery container,
    	dimensions: [800, 350], //width/height of gallery in pixels. Should reflect dimensions of the images exactly
    	imagearray: [
    		["http://www.chaoticexotics.ca/images/frame1.jpg", "", "", ""],
    		["http://www.chaoticexotics.ca/images/frame2.jpg", "", "", ""],
    		["http://www.chaoticexotics.ca/images/frame3.jpg", "", "", ""],
    		["http://www.chaoticexotics.ca/images/frame4.jpg", "", "", ""],
    		["http://www.chaoticexotics.ca/images/frame5.jpg", "", "", ""],
    		["http://www.chaoticexotics.ca/images/frame6.jpg", "", "", ""],		
    		["http://www.chaoticexotics.ca/images/frame7.jpg", "", "", ""]		
    	],
    	autoplay: [true, 2500, 2], //[auto_play_boolean, delay_btw_slide_millisec, cycles_before_stopping_int]
    	persist: false, //remember last viewed slide and recall within same session?
    	fadeduration: 500, //transition duration (milliseconds)
    	oninit:function(){ //event that fires when gallery has initialized/ ready to run
    		//Keyword "this": references current gallery instance (ie: try this.navigate("play/pause"))
    	},
    	onslide:function(curslide, i){ //event that fires after each slide is shown
    		//Keyword "this": references current gallery instance
    		//curslide: returns DOM reference to current slide's DIV (ie: try alert(curslide.innerHTML)
    		//i: integer reflecting current image within collection being shown (0=1st image, 1=2nd etc)
    	}
    })
     
    </script>
    Any help with this would be greatly appreciated. I may just be missing something simple, but I can't figure it out!
    Last edited by wyllomoon; 12-15-2010 at 12:46 PM. Reason: marked resolved

  2. #2
    Join Date
    Jan 2008
    Posts
    4,168
    Thanks
    28
    Thanked 628 Times in 624 Posts
    Blog Entries
    1

    Default

    In your jquery file, replace the top part with:
    Code:
    /* JavaScript Document
     * jQuery 1.2.6 - New Wave Javascript
     *
     * Copyright (c) 2008 John Resig (jquery.com)
     * Dual licensed under the MIT (MIT-LICENSE.txt)
     * and GPL (GPL-LICENSE.txt) licenses.
     *
     * $Date: 2008-05-24 14:22:17 -0400 (Sat, 24 May 2008) $
     * $Rev: 5685 $
     */
    Jeremy | jfein.net

  3. The Following User Says Thank You to Nile For This Useful Post:

    wyllomoon (12-15-2010)

  4. #3
    Join Date
    Aug 2004
    Posts
    10,143
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    Or simply replace the line:

    Code:
    <script type="text/javascript" src="jquery-1.2.6.pack.js"></script>
    in the HEAD section of your page with:

    Code:
    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.min.js"></script>
    DD Admin

  5. The Following User Says Thank You to ddadmin For This Useful Post:

    wyllomoon (12-15-2010)

  6. #4
    Join Date
    Mar 2009
    Posts
    8
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Default

    I apologise for the really late reply. I thought I would get e-mail notifications and I didn't so I had no idea anyone had replied! Thank you both for taking the time to offer advice.

    Unfortunately, I've tried both of these suggestions (not combined, but one at a time) and it's still not showing up.

  7. #5
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    There could be other problems. But both the jquery-1.2.6.pack.js and the simplegallery.js files are corrupt. Go back to the demo page and get fresh copies of each and use those.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  8. The Following User Says Thank You to jscheuer1 For This Useful Post:

    wyllomoon (12-15-2010)

  9. #6
    Join Date
    Mar 2009
    Posts
    8
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Default

    Well, that worked! I can't say that I understand it because I'm still an amateur at best and I downloaded the files from DD again just last week, but this time the gallery is up and running again!

    Thank you so much for your help!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •