Results 1 to 3 of 3

Thread: Ultimate Fade-in slideshow (v2.4)

  1. #1
    Join Date
    Dec 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Ultimate Fade-in slideshow (v2.4)

    1) Problem Ultimate Fade-in slideshow (v2.4)

    2) http://www.robciucionut.info/1

    3) Slideshow.js file I created, I implemented the code but do not know how to display the downloaded. I do not know why. Please help me.

    Thanks.

    4) http://www.dynamicdrive.com/dynamici...nslideshow.htm

    or, ATTACHED BELOW (see #3 in guidelines below):

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    That's actually version 1.51 of the slideshow. To get it working requires two things:

    1. In the js/slideshow.js file, the paths to the images are wrong. These should be relative to the page that is using the script, not to the script. Change this:

      Code:
      var fadeimages=new Array()
      //SET IMAGE PATHS. Extend or contract array as needed
      fadeimages[0]=["../imgs/1.png", "", ""]
      fadeimages[1]=["../imgs/2.png", "", ""]
      fadeimages[2]=["../imgs/3.png", "", ""]
      fadeimages[3]=["../imgs/4.png", "", ""]
      fadeimages[4]=["../imgs/5.png", "", ""]
      fadeimages[5]=["../imgs/6.png", "", ""]
      fadeimages[6]=["../imgs/7.png", "", ""]
      to:

      Code:
      var fadeimages=new Array()
      //SET IMAGE PATHS. Extend or contract array as needed
      fadeimages[0]=["imgs/1.png", "", ""]
      fadeimages[1]=["imgs/2.png", "", ""]
      fadeimages[2]=["imgs/3.png", "", ""]
      fadeimages[3]=["imgs/4.png", "", ""]
      fadeimages[4]=["imgs/5.png", "", ""]
      fadeimages[5]=["imgs/6.png", "", ""]
      fadeimages[6]=["imgs/7.png", "", ""]
      If there's ever any question, the absolute paths may be used.


    2. In the style.css file, this rule at the beginning:

      Code:
      * {
      	margin: 0px;
      	height: 0px;
      }
      is causing some important part of the slideshow to disappear. It's probably a typo anyway, change it to:

      Code:
      * {
      	margin: 0px;
      	padding: 0px;
      }


    There may still be other problems, but taking care of those two things will get it working.

    Also, where you have on the page:

    HTML Code:
    <script type="text/javascript" src="js/slideshow.js"></script>
    In order to follow Dynamic Drive's Terms of Use, that needs to be:

    HTML Code:
    <script type="text/javascript" src="js/slideshow.js">
    
    /***********************************************
    * Ultimate Fade-In Slideshow (v1.51): (c) Dynamic Drive (http://www.dynamicdrive.com)
    * Visit http://www.dynamicdrive.com/ for this script and 100s more.
    ***********************************************/
    
    </script>
    See Dynamic Drive's usage terms, which, among other things, state that the script credit must appear in the source code of the page(s) using the script. Please reinstate the notice.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Dec 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks very much for your help. The problem was solved.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •