Results 1 to 5 of 5

Thread: Jim's DHTML Menu, Font issue

  1. #1
    Join Date
    Sep 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Jim's DHTML Menu, Font issue

    I have been messing around some with the DHTML Menu v5.7 and I truly love it. But I have one problem. On the website I'm producing I'm using font face "Trebuchet MS" and when trying to use it with your menu it ****s up in IE6 (prob all IE)

    The bottom border disappears in the main horizontal menu and the horizontal borders disappears in the submenus.

    tried altering the .js files with this.fontFace = "trebuchet ms"; but no luck

    Do you think it's possible to fix this?

    Would love an answer

  2. #2
    Join Date
    Aug 2004
    Location
    Brighton
    Posts
    1,563
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Hey mindweaver,

    File config.js

    menus[0] = new menu(22, "horizontal", 160, 10, -2, -2, "#CACAFF", "#0000A0", "Trebuchet MS", 9,
    "bold", "bold", "black", "white", 1, "gray", 2, "rollover:images/tri-down1.gif:images/tri-down2.gif", false, true, true, true, 12, true, 4, 4, "black");
    menus[0].addItem("http://www.dynamicdrive.com", "", 100, "center", "Home", 0);
    menus[0].addItem("#", "", 120, "center", "Web Building", 1);
    menus[0].addItem("#", "", 100, "center", "News", 2);
    menus[0].addItem("#", "", 110, "center", "Search", 4);

    No probs if you only change this, i'm using Internet Explorer 6 (Win XP Service Pack 2).

    cr3ative
    A retired member, drop me a line through my site if you'd like to find me!
    cr3ative media | read the stickies

  3. #3
    Join Date
    Sep 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Nope it doesn't work. IE6, winxp sp1

    works fine in mozilla firefox 0.9.3.


    This is how it looks with:
    menus[0] = new menu(18, "horizontal", -1, 70, -1, -1, "#898E8E", "#69AD83", "Trebuchet MS", 8,
    "normal", "normal", "#FFFFFF", "#FFFFFF", 1, "#FFFFFF", 1, "", false, true, true, false, 6, false, 4, 4, "black");



    And this is how it looks with:

    menus[0] = new menu(18, "horizontal", -1, 70, -1, -1, "#898E8E", "#69AD83", "Arial", 8,
    "normal", "normal", "#FFFFFF", "#FFFFFF", 1, "#FFFFFF", 1, "", false, true, true, false, 6, false, 4, 4, "black");




    At first I thought it was the space in "Trebuchet MS" but I have tried with "New Times Roman" and that worked fine. So Strange.
    Last edited by mindweaver; 09-08-2004 at 07:18 PM.

  4. #4
    Join Date
    Aug 2004
    Location
    Brighton
    Posts
    1,563
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    It could well be that treb.ms is a 'taller' font.
    Try changing the menu's vertical size to slightly larger to see if this is the case. As it already works on mine I can't confirm this

    cr3ative
    A retired member, drop me a line through my site if you'd like to find me!
    cr3ative media | read the stickies

  5. #5
    Join Date
    Sep 2004
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Hehe yeah, I was just going to post here that I solved it! As you said, Trebuchet MS is a taller font and that caused my problem.

    Thanks for your help though

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •