Results 1 to 2 of 2

Thread: Ultimate Fade-in slideshow (v2.4) doesn't work in IE

  1. #1
    Join Date
    Sep 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exclamation Ultimate Fade-in slideshow (v2.4) doesn't work in IE

    1) Script Title: Ultimate Fade-in slideshow (v2.4)

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

    3) Describe problem:

    Hi all!

    The script works like a charm with Safari & Firefox, but not with IE(8). With IE all that shows is the loading.gif that just keeps going on and on.

    Please help me!


    Here's the html:
    Code:
    <!DOCTYPE HTML>
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <script type="text/javascript" src="jquery.min.js"></script>
    
    <script type="text/javascript" src="fadeslideshow.js">
    
    /***********************************************
    * Ultimate Fade In Slideshow v2.0- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
    * This notice MUST stay intact for legal use
    * Visit Dynamic Drive at http://www.dynamicdrive.com/ for this script and 100s more
    ***********************************************/
    
    </script>
    
    <script type="text/javascript">
    
    var mygallery=new fadeSlideShow({
    	wrapperid: "fadeshow1", //ID of blank DIV on page to house Slideshow
    	dimensions: [380, 300], //width/height of gallery in pixels. Should reflect dimensions of largest image
    	imagearray: [
    		["21.jpg", "om.html", "iframe", "Läs mer om miljö."],
    		["20.jpg", "kontakt.html", "iframe", "Läs mer om oss."],
    		["22.jpg", "teknik.html", "iframe", "Läs mer om den senaste tekniken."],
    		["23.jpg", "om", "", "Läs mer om världens bästa företag."] //<--no trailing comma after very last image element!
    	],
    	displaymode: {type:'auto', pause:3500, cycles:0, wraparound:false},
    	persist: false, //remember last viewed slide and recall within same session?
    	fadeduration: 500, //transition duration (milliseconds)
    	descreveal: "ondemand",
    	togglerid: ""
    })
    
    
    
    </script>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title>Untitled Document</title>
    <style type="text/css">
    <!--
    .ads {
    	color: #369;
    }
    body {
    	margin-left: 0px;
    	margin-top: 0px;
    }
    -->
    </style>
    </head>
    
    <body>
    <div id="fadeshow1"></div>
    
    <br />
    
    </body>
    </html>
    and here's the edited part of the css:
    Code:
    var fadeSlideShow_descpanel={
    	controls: [['x.png',7,7], ['restore.png',10,11], ['loading.gif',54,55]], //full URL and dimensions of close, restore, and loading images
    	fontStyle: 'normal 11px Verdana', //font style for text descriptions
    	slidespeed: 200 //speed of description panel animation (in millisec)
    }

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    Scripts should follow style in the head. Both should follow title and meta tags.

    Though that should be corrected, it probably isn't the problem.

    If you want more help:

    Please post a link to a page on your site that contains the problematic code so we can check it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •