Results 1 to 3 of 3

Thread: ddsmoothmenu problem in Firefox

  1. #1
    Join Date
    Apr 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default ddsmoothmenu problem in Firefox

    1) Script Title: ddssmoothmenu

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...smoothmenu.htm

    3) Describe problem: I am using ddsmoothmenu on www.mcehosting.com and it works fine on IE. But in Firefox all submenus are shown as open. I mean all there is no opening submenu, all menus are shown. Is there any solution to solve this problem? Thanks.

  2. #2
    Join Date
    Aug 2004
    Posts
    9,902
    Thanks
    3
    Thanked 967 Times in 955 Posts
    Blog Entries
    15

    Default

    The markup for your UL list for the menu contains errors. For example, certain sub ULs that should be contained inside parent LIs are not:

    Code:
    <div id="smoothmenu1" class="ddsmoothmenu">
    <ul>
    <li><a href="http://www.mcehosting.com">Anasayfa</a></li>
    <li><a href="#">Kurumsal</a>
      <ul>
    
      <li><a href="hakkimizda.php">Hakkımızda</a></li>
      <li><a href="referanslarimiz.php">Referanslarımız</a></li>
      <li><a href="banka_bilgileri.php">Banka Bilgilerimiz</a></li>
      </ul>
    </li>
    <li><a href="#">Hosting Hizmetleri</a>
      <ul>
      <li><a href="linux-hosting.php">Linux Hosting</a></li>
    
      <li><a href="windows-hosting.php">Windows Hosting</a></li>
      </ul>
    </li>
    <li><a href="#">Alan Adı Hizmetleri</a></li>
      <ul>
      <li><a href="check.php">Alan Adı Tescil</a></li>
      <li><a href="transcheck.php">Alan Adı Transfer</a></li>
        <li><a href="pricing.php">Alan Adı Ücretleri</a></li>
    
        </ul>
         <li><a href="#">Web Hizmetleri</a></li>
         <ul>
      <li><a href="web-tasarim.php">Web Tasarım</a></li>
      <li><a href="web-yazilim.php">Web Yazılım</a></li>
        <li><a href="web-yedekleme.php">Web Yedekleme</a></li>
        </ul>
    
          <li><a href="#">Destek</a></li>
         <ul>
      <li><a href="support.php">Destek Merkezi</a></li>
      <li><a target="_blank" href="cms_kullanim_kilavuzu.pdf">CMS Kullanım Kılavuzu</a></li>
      <li><a target="_blank" href="http://www.epostamerkezi.com">Web Mail</a></li>
      <li><a target="_blank" href="http://cp.osbhosting.com:8080/psoft/servlet/psoft.hsphere.CP">Kullanıcı Paneli</a></li>
    
      <li><a href="ShowMyPC3010.exe">Uzaktan Yardım</a></li>     
        </ul>
        <li><a href="contact.php">İletişim</a></li>
    
      </li>
      </ul>
    </li>
    </ul>
    </div>
    You'll want to check the entire markup for such errors.
    DD Admin

  3. #3
    Join Date
    Apr 2010
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you for your interest first. But I did your suggest and I corrected the code but result is not change. Menu is working fine on IE but on Firefox it is not working correctly.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •