Results 1 to 3 of 3

Thread: fadeslideshow not working on IE (any version)

  1. #1
    Join Date
    Dec 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default fadeslideshow not working on IE (any version)

    1) Script Title: Ultimate Fade-in slideshow

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...nslideshow.htm

    3) Describe problem: On all versions of IE, I'm getting the following error (and the slideshow will not run):
    Line: 38
    Char: 3
    Error: 'imagearray[...].0' is null or not an object
    Code: 0
    URL: http://www.gromfiles.com/index.html

    It works on Sarari, Firefox, etc. but I have quite a few users using IE (of course). I'd really like to figure this one out. I've re-added and re-added the script making sure I wasn't making a typo anywhere.
    Thanks for your time and help (and great software).

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,000
    Thanks
    44
    Thanked 3,198 Times in 3,160 Posts
    Blog Entries
    12

    Default

    From your page's source code:

    Code:
    <script type="text/javascript">
    
    var mygallery=new fadeSlideShow({
    	wrapperid: "fadeshow1", //ID of blank DIV on page to house Slideshow
    	dimensions: [950, 587], //width/height of gallery in pixels. Should reflect dimensions of largest image
    	imagearray: [
    		["Photo_WSA.jpg","http://mcdanielphoto.com/mcdphoto-gallery/thumbnails.php?album=113", "_parent", ""],
    		["photo7.jpg", "http://mcdanielphoto.zenfolio.com/p696419626", "_parent", ""],
    		["photo1.jpg", "", "", ""],
    		["photo5.jpg", "http://www.primesurfphotos.com", "_parent", ""],
    		["photo2.jpg", "", "", ""],
    		["photo3.jpg", "", "", ""],
    		["photo4.jpg", "http://mcdanielphoto.com/mcdphoto-gallery/thumbnails.php?album=110", "_parent", ""],
    		["photo6.jpg", "http://www.vimeo.com/7698290", "_parent", ""],
    		["photoBMX.jpg", "", "", ""],
    		["photoBMX2.jpg", "", "", ""],
    		["photoBMX3.jpg", "", "", ""],//<--no trailing comma after very last image element!image element!
    	],
    	displaymode: {type:'auto', pause:2500, cycles:0, wraparound:false},
    	persist: false, //remember last viewed slide and recall within same session?
    	fadeduration: 500, //transition duration (milliseconds)
    	descreveal: "ondemand",
    	togglerid: ""
    })
    
    
    </script>
    No comma means no comma. Get rid of the red one.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Dec 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Thanks!

    Thanks for the immediate reply. Man, I've been moving around the shots so much I totally missed that.
    Sorry for the wasted bandwidth. I should have been able to see that one.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •