Results 1 to 4 of 4

Thread: ddsmoothmenu not working in Chrome + Safari

  1. #1
    Join Date
    Jul 2009
    Posts
    44
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Default ddsmoothmenu not working in Chrome + Safari

    1) Script Title:
    ddsmoothmenu
    2) Script URL (on DD):
    http://www.dynamicdrive.com/dynamici...smoothmenu.htm
    3) Describe problem:
    The menu works perfectly in IE8 and FF but in Chrome and FF I only see the background image, everything else is blank.
    http://koltora.com/new_game/
    Thank for the help
    Chaim

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    Your page is very quirky (not written with web standards in mind). However, in addition to that, you have an open comment tag which never gets closed at the beginning of the body area. Any browser would be within their rights to interpret this to mean that there is no content. Get rid it of it and your problems will begin to be solved, but there will be other issues.

    I would suggest validating your page*. But simply getting rid of the highlighted section may be enough for your purposes:

    Code:
    <body
    onload="Clone('clone');Static();"
    background="image/notebook.jpg" leftmargin="0" topmargin="0"/>
    		
    
    </div><!--	<div align="center">
    		<img border="0" src="questions/intro.jpg" width="1273" height="458" align="left" style="position: absolute; left: 0; top: 0">
    	<p>
    	<blockquote>
    </script>
    <div id="smoothmenu2" class="ddsmoothmenu-v">
    <ul>
    Nice looking page by the way.

    * To validate a page, see:

    http://validator.w3.org/
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. The Following User Says Thank You to jscheuer1 For This Useful Post:

    Chaim (10-27-2009)

  4. #3
    Join Date
    Jul 2009
    Posts
    44
    Thanks
    7
    Thanked 0 Times in 0 Posts

    Default

    Wow! That did it. Being a beginner is difficult. Thanks for your help. I will follow your suggestions and appreciate any other fixes you can suggest.

  5. #4
    Join Date
    Jul 2011
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I am having this problem where the dynamic menues don't behave in Safari and Chrome. My page appears to be valid and things work fine in IE and FF. Please review and comment
    http://dev.bichon.org

    Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •