Results 1 to 6 of 6

Thread: Cell background problem in Firefox

  1. #1
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Question Cell background problem in Firefox

    Hi,

    I have a table in which the first row has no border and a background image and the other rows have borders but no background images.

    Firefox seems to leave a space at the beginning of the first row and it doesn't do it in IE :

    FF


    IE


    Do you know what could be causing this ?

  2. #2
    Join Date
    Jan 2006
    Location
    Ft. Smith, AR
    Posts
    795
    Thanks
    57
    Thanked 129 Times in 116 Posts

    Default

    Could we see a link to the problem page?
    --------------------------------------------------
    Reviews, Interviews, Tutorials, and STUFF
    --------------------------------------------------
    Home of the SexyBookmarks WordPress plugin

  3. #3
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default

    It's on my localhost.

    Here is the part of the HTML:
    HTML Code:
    <!-- start: forumbit_depth1_cat -->
    <table border="0" cellspacing="0" cellpadding="4" class="tborder">
    	<thead>
    		<tr>
    
    			<td class="thead" colspan="5">
    				<div class="cat_icon">
    					<div class="expcolimage">
    						<img src="images/lp3e/collapse.gif" id="cat_1_img" class="expander" alt="[-]" title="[-]" />
    					</div>
    						<strong>
    						<span style="position: relative; left: 26px;">
    						<a href="forumdisplay.php?fid=1">My Category</a>
    
    						</span>
    						</strong>
    				</div>
    			</td>
    		</tr>
    	</thead>
    	<tbody style="" id="cat_1_e">
    	<!-- start: forumbit_depth2_forum -->
    <tr>
    
    	<td id="forum_icon" rowspan="2" class="trow1" align="center" valign="middle" width="1">
    		<img src="images/lp3e/off.gif" alt="Ce forum ne contient pas de nouveaux messages" title="Ce forum ne contient pas de nouveaux messages" class="ajax_mark_read" id="mark_read_2" />
    	</td>
    	<td rowspan="2" class="trow1" valign="middle" width="100%">
    		<strong><a href="forumdisplay.php?fid=2">My Forum</a></strong>
    		<div class="smalltext">Test description.<br /><!-- start: forumbit_subforums -->
    <strong>Sous-Forums :</strong> <img src="images/lp3e/minioff.gif" alt="Ce forum ne contient pas de nouveaux messages" title="Ce forum ne contient pas de nouveaux messages" class="subforumicon ajax_mark_read" id="mark_read_5" /><a href="forumdisplay.php?fid=5" title="">Sub Forum</a>
    
    <!-- end: forumbit_subforums --></div>
    	</td>
    	<td colspan="2" class="trow1" valign="middle" style="white-space: nowrap; min-width: 275px;"><!-- start: forumbit_depth2_forum_lastpost -->
    <div><a href="showthread.php?tid=1&amp;action=lastpost" title="Test">Test</a>
    <br />
    <div class="smalltext">par <a href="member.php?action=profile&amp;uid=2">Tester</a> 07-27-2009 10:09 PM
    </div>	
    </div>
    <!-- end: forumbit_depth2_forum_lastpost --></td>
    </tr>
    <tr>
    
    	<td class="trow1" valign="middle" align="center" style="white-space: nowrap">Sujets : 3</td>
    	<td class="trow1" valign="middle" align="center" style="white-space: nowrap">Messages : 8</td>
    </tr>
    <!-- end: forumbit_depth2_forum -->
    	</tbody>
    </table>
    <br />
    <!-- end: forumbit_depth1_cat -->
    The class="thead" is the one with the bg problem.

  4. #4
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    2,023
    Thanks
    17
    Thanked 319 Times in 318 Posts
    Blog Entries
    3

    Default

    There shouldn't be any spaces before and after inline tags, try this instead:
    HTML Code:
    <thead>
    	<tr>
    		<td class="thead" colspan="5"><div class="cat_icon">
    			<div class="expcolimage"><img src="images/lp3e/collapse.gif" id="cat_1_img" class="expander" alt="[-]" title="[-]" /></div>
    			<strong><span style="position: relative; left: 26px;"><a href="forumdisplay.php?fid=1">My Category</a></span></strong></div></td>
    	</tr>
    </thead>
    Good luck!
    Eddy Proca
    I love Dropbox. Get it through my girlfriend's referral link (I reached my limit) and both you and her get 500 MB extra! Thanks and you're welcome!

  5. #5
    Join Date
    Jul 2009
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default

    Didn't change anything.

  6. #6
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    2,023
    Thanks
    17
    Thanked 319 Times in 318 Posts
    Blog Entries
    3

    Default

    Do the same with all image tags. If it still doesn't work, please post a link to your site.

    Good luck!
    Eddy Proca
    I love Dropbox. Get it through my girlfriend's referral link (I reached my limit) and both you and her get 500 MB extra! Thanks and you're welcome!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •