Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Help with IE8 and Lytebox

  1. #1
    Join Date
    Jul 2008
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Help with IE8 and Lytebox

    Hello!

    I'm using Lytebox on my site, and I recently upgraded my browser to IE8.

    When I upgraded to IE8, I noticed that the Lytebox doesn't work good: It sometimes opens and immediately closed, and sometimes it opens, but without draken the scenn, like it should.

    Here is a link to the Lytebox on my site:
    https://www.epays.co.il/Demo.asp (Just click on one of the "ePays" buttons in the content area, or click on the third link near the main picture - the one with the screen icon). Don't forget to test it using IE8.


    I'm posting the question here, because the forum on the Lytebox site is inactive.

    Can someone help me?

    Thank's,
    Yarin.

  2. #2
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    2,023
    Thanks
    17
    Thanked 319 Times in 318 Posts
    Blog Entries
    3

    Default

    I does it in Fx3.0.10 as well (sorry for the bad news, I'll take a look to see what's wrong).
    Eddy Proca
    I love Dropbox. Get it through my girlfriend's referral link (I reached my limit) and both you and her get 500 MB extra! Thanks and you're welcome!

  3. #3
    Join Date
    Jul 2008
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Anyone...?

  4. #4
    Join Date
    Jul 2008
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    .....?

  5. #5
    Join Date
    May 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

  6. #6
    Join Date
    Nov 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    It might be a little late, but try to activate the compatibility mode of the IE8 by adding the following line to the HEAD section:

    Code:
    <meta http-equiv="X-UA-Compatible" content="IE=7" />
    By doing so visitors of your page using Internet Explorer 8 will see it from an IE7 point of view and everything works fine. At least on my homepage it worked out fine.

  7. #7
    Join Date
    Nov 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default LYTEBOX now working on IE8!!!!

    Hey people, i use Lytebox and it works fine on firefox and Google Chrome but, i noticed when you test lytebox on Internet Explorer 8 it doesnt work correctly, well i have a good new, Lytebox is working perfectly now!!! i just took the file lytebox.js from www.dolem.com i didnt even edited it , i just copy and pasted the .js and w00t its working now, i know this is not the best way to fix the problem, but at least the script is working n my website now

    if you want the lytebox.js go here: http://www.dolem.com/lytebox/lytebox_demo.js

  8. #8
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,377
    Thanks
    77
    Thanked 3,421 Times in 3,382 Posts
    Blog Entries
    12

    Default

    Quote Originally Posted by nahomy_a View Post
    Hey people, i use Lytebox and it works fine on firefox and Google Chrome but, i noticed when you test lytebox on Internet Explorer 8 it doesnt work correctly, well i have a good new, Lytebox is working perfectly now!!! i just took the file lytebox.js from www.dolem.com i didnt even edited it , i just copy and pasted the .js and w00t its working now, i know this is not the best way to fix the problem, but at least the script is working n my website now

    if you want the lytebox.js go here: http://www.dolem.com/lytebox/lytebox_demo.js
    Using the script is a good solution. I'm thinking it may have been updated to work in IE 8 or in some other fashion that also fixed whatever the problem was in IE 8. It is also entirely possible that there never was a problem in IE 8, just sloppy HTML coding on the part of those that were having trouble with it in that browser. Many browsers, especially IE browsers, though not just IE browsers, require valid (or at least valid in certain ways) HTML code for any of these 'box' type scripts to function properly.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  9. #9
    Join Date
    Mar 2010
    Location
    Amsterdam, Netherlands
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    It also doesn't display the close, next, previous, play and pause buttons anymore in IE8. It is not a problem with HTML coding on my page. Even on the page of Lytebox itself it gives problems when opening example of a slideshow...

  10. #10
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,377
    Thanks
    77
    Thanked 3,421 Times in 3,382 Posts
    Blog Entries
    12

    Default

    Quote Originally Posted by dimitrivisser View Post
    Even on the page of Lytebox itself it gives problems when opening example of a slideshow...
    You are correct. For now, pending an update, if you want to use Lytebox:

    http://www.dolem.com/lytebox/

    you will have to force IE 7 compatibility mode for your page(s) that use it by including this meta tag:

    HTML Code:
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7">
    as one of the first in your document. Place it before the title tag in the head. (untested, but should work)

    If you want more help:

    Please post a link to a page on your site that contains the problematic code so we can check it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •