Results 1 to 3 of 3

Thread: Having Problems with Simple Controls Gallery

  1. #1
    Join Date
    Dec 2008
    Posts
    10
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default Having Problems with Simple Controls Gallery

    1) Script Title:
    Simple Controls Gallery v1.3

    2) Script URL (on DD):
    http://www.dynamicdrive.com/dynamici...plegallery.htm

    3) Describe problem:
    The gallery works and plays fine in Firefox, but does not show up in IE and gives me this error message:

    Line: 35
    Char: 3
    Error: 'imagearray[...].0' is null or not an object
    http://flammabledesign.com/PurelineKennels/Test/ ("males" & "females" pages)

    Any help would be immensely appreciated.
    Last edited by Snookerman; 05-02-2009 at 12:36 PM. Reason: added [quote] tags and “Resolved” prefix

  2. #2
    Join Date
    Aug 2004
    Posts
    10,140
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    There should be no trailing comma (,) following the very last array element of imagearray for both instances of the gallery on your page, for example:

    Code:
    	imagearray: [
    		["royce1.jpg", "royce1_lg.jpg", "_new", ""],
    		["royce2.jpg", "royce2_lg.jpg", "_new", ""],
    		["royce3.jpg", "royce3_lg.jpg", "_new", ""],
    		["royce4.jpg", "royce4_lg.jpg", "_new", ""],
    		["royce5.jpg", "royce5_lg.jpg", "_new", ""],
    	],
    And:

    Code:
    	imagearray: [
    		["comingsoon.gif", "", "", ""],
    	],
    Remove the coma in red, as IE will choke on them.
    DD Admin

  3. The Following User Says Thank You to ddadmin For This Useful Post:

    dineonyourdesign (05-02-2009)

  4. #3
    Join Date
    Dec 2008
    Posts
    10
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Ahh, like a charm! Thank you!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •