Results 1 to 5 of 5

Thread: Conveyor belt slideshow

  1. #1
    Join Date
    Feb 2009
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Conveyor belt slideshow

    1) Script Title: Conveyor belt slideshow

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...tslide_dev.htm

    3) Describe problem: the slideshow starts from the middle of the page and everytime the slide is done it starts back from the middle of the page again. how do i set it to get it keep going?

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    It starts where? Um, if you look at the actual demo page (where the code has been updated from the developer view page you linked to, but that isn't important as far as this issue goes), I think not:

    http://www.dynamicdrive.com/dynamici...rightslide.htm

    Anyways, what you are describing sounds like you are using the script on a page that is using the align="center" attribute, and/or text-align:center; style, and/or the <center> tag in inappropriate ways visa vis this script and most versions of the IE browser which inherits centering in nonstandard ways.

    You can center many elements more appropriately using the margin: 0 auto; style under a valid URL DOCTYPE, or you can ensure that the immediate container of the conveyor has the align="left" attribute or the text-align: left; style.

    But from what little information you give, it might be something else.

    If you want more help:

    Please post a link to the page on your site that contains the problematic code so we can check it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Feb 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Possibly same issue

    I think I have the same issue. What happens is that when the image in the middle of the array leaves the scroller on the left, the remaining images immediately disappear. This doesn't break the scroll however. It only happens in IE7. In FF it works fine.

    I was inter-mixing JS to create the image array from my directory so to rule out my modifications as the issue I uploaded the script as is on its own page with nothing else. Still continues to happen.

    Here is my script on our homepage:
    http://yummyindialounge.com

    Here it is by itself:
    http://yummyindialounge.com/slidertest.php

    Suggestions anyone;

    Jason

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    You do have the same problem, and another one. You should use align left for the table cell:

    Code:
    <td height="150" align="left"><script type="text/javascript">
      /***********************************************
    * Conveyor belt slideshow script-  Dynamic Drive DHTML code library (www.dynamicdrive.com)
    * This notice . . .
    The other problem is that there aren't enough images, so the conveyor runs out before it can repeat.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  5. #5
    Join Date
    Feb 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks so much John, the changes worked great. I had to use some temp pics to test it but I will have more real ones coming soon.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •