Results 1 to 3 of 3

Thread: Step Carousel 'stepcarousel' is undefined

  1. #1
    Join Date
    Jan 2009
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default Step Carousel 'stepcarousel' is undefined

    1) Script Title: Step Carousel Viewer

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...epcarousel.htm

    3) Describe problem: Script works perfectly offline, doesnt load when uploaded to the net.

    Please help! I am so baffled. I have the step carousel viewer working perfectly when i preview my site off of dreamweaver. However, when i uploaded the whole site and view it, step carousel doesnt load. i clicked the problem report and i get the message: 'stepcarousel' is undefined.

    The site is studioparis.com.au (this will link to the gallery page).

    i have viewed the source for the actual dd code page where there are examples, and they are the same as mine. i am so confused as to why this is happening. btw i dont actually know javascript, so please use laymans terms!

    my theory is that ie, ff and opera dont seem to recognise that there is javascript on the page. when i preview the site, i get that popup message asking if i want to activate scripts. but this doesnt happen to the uploaded site. all the source code on the site is viewable. just in case you need to view them the scripts are at studioparis.com.au/Scripts/

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    Both of these (from your source code):

    Code:
    <script type="text/javascript" src="scripts/jquery-1.2.2.pack.js"></script>
    
    <script type="text/javascript" src="scripts/stepcarousel.js">
    
    /***********************************************
    * Step Carousel Viewer script- (c) Dynamic Drive DHTML code library (www.dynamicdrive.com)
    * Visit http://www.dynamicDrive.com for hundreds of DHTML scripts
    * This notice must stay intact for legal use
    ***********************************************/
    
    </script>
    are 404 not found. Perhaps you neglected to upload them, or uploaded them to a different location.

    It's also possible that there is a mismatch in upper/lower case in the path and/or filenames, as these will be ignored locally, but not on the web.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. The Following User Says Thank You to jscheuer1 For This Useful Post:

    stick_theory (01-05-2009)

  4. #3
    Join Date
    Jan 2009
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default

    Oh
    My
    God

    You are freaking GENIUS! such a simple mistake. it was just a matter of changing the 's' to an 'S' and voila. A big virtual kiss on the face to you my good peer!

    I am always looking for the bigger problems and blaming my lack of knowledge of javascript. You have certainly made me look quite foolish .

    Thankyou again! IOU

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •