Results 1 to 4 of 4

Thread: scripts disappearing behind image maps

  1. #1
    Join Date
    Jun 2005
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default scripts disappearing behind image maps

    Im starting up a newblog but im having trouble with one thing. If you try to go to giyang.blogspot.com you might notice that the elastic trail scripts disappears behind the image map. do u have any suggestions to correct this? Im also trying to put in the falling snow script but same thing the snow diasappears behind the image map. Thanks a lot!

  2. #2
    Join Date
    Jun 2005
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    i heard from one of my friends that i can specify a z position to this line. Any ideas as to how???

    <img style="position: absolute; top: 40; left: 100;" border="0" src="http://img.photobucket.com/albums/y203/urbanfaerygraphics/msdj.gif" width="544" height="674" usemap="#Map1">

  3. #3
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    That's z-index. It would go anywhere in the style declaration, like so:
    Code:
    style="z-index:0;position: absolute; top: 40; left: 100;"
    Unfortunately, that won't do much because 0 is the default. If you set the z-index to -1 the image will disappear behind the background of the page. What you need to do is set the z-index of the elements containing the elastic trails to say 10. In one version of that script here on DD, that would mean doing this:
    Code:
    <div id="dot0" style="z-index:10;position: absolute; visibility: hidden; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    <div id="dot1" style="z-index:10;position: absolute; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    <div id="dot2" style="z-index:10;position: absolute; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    <div id="dot3" style="z-index:10;position: absolute; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    <div id="dot4" style="z-index:10;position: absolute; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    <div id="dot5" style="z-index:10;position: absolute; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    <div id="dot6" style="z-index:10;position: absolute; height: 11; width: 11;">
    	<img src="bullet.gif" height=11 width=11>
    </div>
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  4. #4
    Join Date
    Jun 2005
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Thanks a lot

    Actually when i set it to -1 on the image tag it did work. for some reason it did not disappear into the background. In any case, if i have anyproblems i know what to do. thanks a lot!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •