Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Conveyor Belt Script Problem

  1. #1
    Join Date
    Oct 2004
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question DD Scripts: Conveyor Belt Script Problem


    Thanks for the suggestion, is this better?

    Conveyor Belt DD Script:
    Greetings to all;

    The problem that I've had with this (conveyor belt) script is finding a way to close the 'GAP" that appears between the pictures. I'm trying to create a continuous and seamless effect, Im using images that are exactly the same size which should follow one after another seamlessly. I edited the images in Photoshop to where the end of one image attaches exactly to the beginning of the next, and so forth... There is a really large, wide GAP that appears at the end of the last image before the cycle starts again; Any suggestions?

    Any help with this issue would be greatly appreciated.
    - Thanks.

    Last edited by Graffxman; 10-13-2004 at 12:22 AM.

  2. #2
    Join Date
    Aug 2004
    Location
    Brighton
    Posts
    1,563
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Could you demonstrate with an online example?

    cr3ative

    edited 13/10/04
    Last edited by cr3ative; 10-13-2004 at 01:17 PM. Reason: the user acknowledged previous instructions
    A retired member, drop me a line through my site if you'd like to find me!
    cr3ative media | read the stickies

  3. #3
    Join Date
    Aug 2004
    Posts
    10,143
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    As cr3ative mentioned, in the future, please post in the proper format, by including a link to the script on DD, in this case: http://www.dynamicdrive.com/dynamici...rightslide.htm Also, please don't use coloring for the text- the default black instead of blue will do nicely.

    Regarding your question, I try and get to updating this script so the spacing is customizable, most likely late this week or the next.

  4. #4
    Join Date
    Aug 2004
    Posts
    10,143
    Thanks
    3
    Thanked 1,008 Times in 993 Posts
    Blog Entries
    16

    Default

    Ok, script updated so you can specify both the spacing between each image and slideshow rotations.

  5. #5
    Join Date
    Oct 2004
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Dear all

    Sorry, I've another favour to ask someone regarding this conveyor belt script. As a final part, is it possible to have a piece of text set in a table to display information regarding whichever website thumbnail is hovered over?
    I know it can be done in normal coding using swap-image/image restore, but being a JS code area, can this be done?

    Again, many thanks..

    Mike

  6. #6
    Join Date
    Oct 2004
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks DDadmin and Cr3ative;
    Is this good?
    Re: Conveyor Belt Slideshow script
    http://www.dynamicdrive.com/dynamici...rightslide.htm

    You're a Genius!
    I think these revisions will work, I'll try it out on my slideshow and post an online example as soon as possible. Thanks, this seems to be the solution I was looking for; I actually resolved the gap between images by modifying the script,but Im not experienced enough to re-write the code for the ending gap so I just added a background image to the table cell that shows thru the gap; Thanks! -Graffxman

  7. #7
    Join Date
    Oct 2004
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default just play with this

    in the fillup function, line:

    cross_slide2.style.left=actualwidth+X+"px"

    play with the X value.

    in my case a X=9 made the gaps equal with the closing gap, together with "freezing" the font-size at the end of the script:

    write('<div id="test2" style="position:absolute;left:0px;top:0px;font-size:28px"></div>')
    write('<div id="test3" style="position:absolute;left:-1000px;top:0px;font-size:28px"></div>')

  8. #8
    Join Date
    Oct 2004
    Location
    Texas
    Posts
    54
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Lightbulb

    This is my first time posting so I hope I get all the information correct.

    Regarding:
    Conveyor Belt DD Script located at:
    http://www.dynamicdrive.com/dynamici...rightslide.htm
    working example of the changes can be found at:
    http://www.harlowgraphics.com/temp/working.html

    I, too, was having problems with the major gap where the show starts again. The tail end of the "belt" would completely disappear as soon as 1/3 of the first picture appeared on the right hand side. I was able to fix mine by changing the following near the end of the script:

    write('<div style="position:absolute;width:'+sliderwidth+';height:'+sliderheight+';background-color:'+slidebgcolor+'" onMouseover="copyspeed=0" onMouseout="copyspeed=slidespeed">')

    to:

    write('<div style="position:relative;width:'+sliderwidth+';height:'+sliderheight+';background-color:'+slidebgcolor+'" onMouseover="copyspeed=0" onMouseout="copyspeed=slidespeed">')

    Then I played with the slideshowgap variable at the beginning of the script until it seamed in nicely.

    Just something to try.

  9. #9
    Join Date
    Mar 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Gap problem between images

    Quote Originally Posted by ddadmin
    Ok, script updated so you can specify both the spacing between each image and slideshow rotations.

    Can you tell me the error of my way? I've uploaded to http://hellobrooklyn.com/llkfb/

    I'd like to get rid of the gaps between the images.

    Thanks for your help

  10. #10
    Join Date
    Mar 2005
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    This is how I got rid of the gaps...

    -----------------------------------------------------------------
    //Specify gap between each image (use HTML):
    var imagegap=""

    //Specify pixels gap between each slideshow rotation (use integer):
    var slideshowgap=-3
    -----------------------------------------------------------------


    for some reason '-3' fixed it, maybe just experiment with that number
    a bit.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •