Results 1 to 5 of 5

Thread: Advanced Gallery script weird timing change problem?

  1. #1
    Join Date
    Aug 2008
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Unhappy Advanced Gallery script weird timing change problem?

    Hello All,

    1) Advanced Gallery script

    2) http://www.dynamicdrive.com/dynamicindex17/agallery.htm

    3) Describe problem: almost work, first frame up set duration, 2nd frame just get a 1/2 sec. then jumps back to first frame. not sure were to even look for this??

    Also just noticed doesn't seem to be working in FireFox?

    My testpage: http://wyandotte.net/home-test-gallery.htm

    Thanks Rich
    Last edited by rscprod; 08-14-2008 at 03:54 AM. Reason: Addition

  2. #2
    Join Date
    Aug 2008
    Location
    Smiths, AL
    Posts
    164
    Thanks
    30
    Thanked 5 Times in 5 Posts

    Default

    Try adding

    Code:
    window.onload=startgallery
    right under the last section of your code just before the </script> tag

    you have:
    Code:
    if (window.addEventListener)
    window.addEventListener("load", startgallery, false)
    else if (window.attachEvent)
    window.attachEvent("onload", startgallery)
    else if (document.getElementById)
    It should read:
    Code:
    if (window.addEventListener)
    window.addEventListener("load", startgallery, false)
    else if (window.attachEvent)
    window.attachEvent("onload", startgallery)
    else if (document.getElementById)
    window.onload=startgallery

  3. The Following User Says Thank You to Dirt_Diver For This Useful Post:

    rscprod (08-14-2008)

  4. #3
    Join Date
    Aug 2008
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Thanks Dirt_Diver

    that helped some of the issues.

    Almost better, all scripts appear to be where they belong and functioning in both IE & FF...

    Except I am still getting the flicker instead of timed alternateing on the Gallery Script in both browsers.

    My testpage: http://wyandotte.net/home-test-gallery.htm

    -Rich

  5. #4
    Join Date
    Aug 2008
    Location
    Smiths, AL
    Posts
    164
    Thanks
    30
    Thanked 5 Times in 5 Posts

    Default

    Does it do the same thing if you swap the two ads?

  6. The Following User Says Thank You to Dirt_Diver For This Useful Post:

    rscprod (08-14-2008)

  7. #5
    Join Date
    Aug 2008
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Hello again,

    Yes, it still is doing the flicker after I fliped the ad,

    Then, just to check, I added a 3rd ad to see what would happen and it
    now flickers past every other ad (appearing to jump from ad 1 (skip 2) to 3
    (skip 1) to 2 (skip 3) to 1 ect.

    My testpage: http://wyandotte.net/home-test-gallery-3ads.htm

    Also: I just noticed that if I switch the gallery to manual mode then back to automatic, the gallery seams to then work properly.
    This happens in both IE & FF.

    Thanks - Rich C.
    Last edited by rscprod; 08-14-2008 at 09:29 PM. Reason: Added Info.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •