Results 1 to 3 of 3

Thread: multiple javascripts on page, at least one won't work

  1. #1
    Join Date
    Aug 2008
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default multiple javascripts on page, at least one won't work

    Hello all,
    I'm trying to put multiple javascripts on one page, when I do at least one won't work.

    The scripts I'm attempting to use are: HVmenu, Random Image Script, Advanced Gallery script, (these three were working fine together)
    Testpage: http://wyandotte.net/home-test.htm

    then when I added Scrollable content script II the HVmenu disappeared.
    Testpage: http://wyandotte.net/home-test2.htm

    So then someone suggested moving the onloads to the body tag which I did,
    The HVmenu came back but the Scrollable content script II stopped working.
    Testpage: http://wyandotte.net/home-test-onload.htm

    Any ideas out there, I'm kind of stumped?
    I'm sure it's probably something really simple & I am just a big bonehead!

    Thanks Rich

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    That (putting multiple onload calls in the body tag) is one way of resolving onload conflicts. However, you should also remove the onload calls from the scripts themselves or wherever else they may appear, and the proper syntax for onload in the body tag includes the parenthetical suffix:

    Code:
    onload="startgallery(); getcontent_height();"
    Make sure the calls are spelled correctly, upper and lower case letters matter. What's the onload for HVmenu? It cannot be either of those.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. The Following User Says Thank You to jscheuer1 For This Useful Post:

    rscprod (08-14-2008)

  4. #3
    Join Date
    Aug 2008
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Talking Issue resolved, Thank you

    John you rock!!!

    The prob was with the parenthetical suffix.

    Thank you so much

    - Rich

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •