Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 51

Thread: CMotion and FiF issue

  1. #11
    Join Date
    Oct 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by jscheuer1
    I looked into this further and the real fix is to give the <nobr> tag on the display page an id like so:
    HTML Code:
    <div id="motioncontainer" style="position:relative;width:400px;height:150px;overflow:hidden;">
    <div id="motiongallery" style="position:absolute;left:0;top:0;white-space: nowrap;">
    
    <nobr id="trueContainer"><a href . . . snip!
    Then in the original motiongallery.js script, change this line:
    Code:
    actualwidth=document.all? cross_scroll.offsetWidth : document.getElementById("temp").offsetWidth
    to this:
    Code:
    actualwidth=document.all? cross_scroll.offsetWidth : document.getElementById("trueContainer").offsetWidth
    There now, that's alot easier, huh?
    =================================The Cmotion Gallery script is not working in Netscape and Firefox (Mozilla)

    Can someone advise me on this?

    Thanks,

  2. #12
    Join Date
    Oct 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    The Cmotion gallery script is not working in Netscape and Firefox (Mozilla).

    Can someone advise me on this?

    Thanks

  3. #13
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,076
    Thanks
    44
    Thanked 3,216 Times in 3,178 Posts
    Blog Entries
    12

    Default

    samarita,

    The current Cmotion script on DD here has already been updated to reflect the changes I laid out in this thread. So, to begin with, make sure you are using the most recent version. As far as any problem you may be having beyond that (not covered by TheRec's tweak outlined in this thread), I would need to see your implementation:

    PLEASE: Include the URL to your problematic webpage that you want help with.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  4. #14
    Join Date
    Nov 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Help needed

    Hi!

    I'm using this really cool script and it works great in IE but I can't get it to work in Firefox and Netscape. I've tried with the newer version but then it doesn't work at all. Can somebody help me please.

    Here's the URL Link

    Martin

  5. #15
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,076
    Thanks
    44
    Thanked 3,216 Times in 3,178 Posts
    Blog Entries
    12

    Default

    Your HTML markup doesn't follow the intended design. You have for some reason used:

    HTML Code:
    <nobr id="trueContainer">
    as a preface for each individual image in the gallery and neglected to close any of those tags with an </nobr> tag. The intended design is for only one:

    HTML Code:
    <nobr id="trueContainer">
    at the beginning of the entire content and then a single </nobr> at the end of it, like so:

    HTML Code:
    <nobr id="trueContainer"><a href="visa2.asp?ItemID=photos/Separe01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Separe01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Separe02.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Separe02.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Separe03.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Separe03.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/bord01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_bord01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Restu01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Restu01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Bordnära01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Bordnära01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Lampa1.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Lampa1.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/fönstbord01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_fönstbord01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Rundabord01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Rundabord01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Rundabord02.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Rundabord02.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Fåtölj01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Fåtölj01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Lounge01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Lounge01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Rundfönst01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Rundfönst01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Rundsofa01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Rundsofa01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Väg01.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Väg01.jpg" alt="" border="0"></a>
    <a href="visa2.asp?ItemID=photos/Väg02.jpg&kategori=others&sub_kat=1&rubrik=Centro"><img src="photos/thumbs/small_Väg02.jpg" alt="" border="0"></a></nobr>
    Taking care of that will go a long way toward fixing things in those two browsers you mentioned, it may even be the only problem.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  6. #16
    Join Date
    Nov 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you so much for the fast reply! I'll try it right away!

    Martin

  7. #17
    Join Date
    Dec 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Is there any way to add labels to the pictures in the gallery. For instance, it would be great if you could put the name of each image below or above the picture, and it scrolls along the picture. Unfortunately, tables does not seem to work in the script.

    Thanks in Advance.
    Mahk

  8. #18
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    29,076
    Thanks
    44
    Thanked 3,216 Times in 3,178 Posts
    Blog Entries
    12

    Default

    This type of syntax worked here:

    HTML Code:
    <table id="trueContainer"><tr><td><a href="javascript:enlargeimage('dynamicbook1.gif')"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="javascript:enlargeimage('dynamicbook1.gif', 300, 300)"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="http://www.dynamicdrive.com"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="#"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="#"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="#"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="#"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="#"><img src="dynamicbook1.gif" border=1></a><br>caption</td><td><a href="#"><img src="dynamicbook1.gif" border=1></a><br>caption</td></tr></table>
    Substitute it for:

    HTML Code:
    <nobr id="trueContainer"> . . . </nobr>
    Notes: to center the captions under the images, put this in the head of the page:

    Code:
    <style type="text/css">
    #trueContainer td {
    text-align:center;
    }
    </style>
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  9. #19
    Join Date
    Dec 2005
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Great! I was close, I was just putting the table in the nobr... Thank a ton! It looks great. www.thepostshow.com

    All the best,
    Mahk

  10. #20
    Join Date
    Dec 2005
    Location
    Latvia
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Hi, guys,
    I have a little problem with this script, I tested it and all gone well but when I added to my real web page it wasn't working (thumbnail pictures weren't moving), so I carefully searched the problem and come to conclusion that the thing why this script doesn't want to work is my onload images in body tag... when I remove them, all works fine, when I add them back the gallery just isn't moving anymore.
    Does anyone have a good idea how to solve this thing?
    Last edited by Raymond_b; 12-17-2005 at 01:18 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •