Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: All Levels Navigational Menu - 1px Off Bug

  1. #11
    Join Date
    Aug 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I have the same problem on my site:

    http://www.cis.hut.fi/tvatanen/sompa/about.shtml

    The bug seems to be almost 'random', but it's very annoying. Sometimes the submenu disappears no matter how 'fast' you move your mouse.. I hope you can duplicate the error on my site.

    I didn't find the same problems with the demos either. So I'm a little bit confused..

    I'm using FF3 on Ubuntu

    Thanks in advance,

    Tommi
    Last edited by tommivat; 08-01-2008 at 12:19 PM. Reason: browserinfo

  2. #12
    Join Date
    Aug 2004
    Posts
    10,138
    Thanks
    3
    Thanked 1,007 Times in 992 Posts
    Blog Entries
    16

    Default

    Tommi:
    Please include browser/ OS info.

  3. #13
    Join Date
    Aug 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Update:

    I made some experiments and found that there is something about padding that affects this bug..

    .mattblackmenu li a { padding: 6px 20px }

    if I alter the vertical padding (6px by deafult) either to very small (1px) or much bigger (over 10px) the bug seems to disappear.. Weird, I think..

    Edit: It seems that this behaviour is totally random.. So don't make any conclusions...
    Last edited by tommivat; 08-01-2008 at 02:29 PM. Reason: update2

  4. #14
    Join Date
    Aug 2004
    Posts
    10,138
    Thanks
    3
    Thanked 1,007 Times in 992 Posts
    Blog Entries
    16

    Default

    Tommi:
    Regarding extra padding/ margins throwing the menu off, seems like a missing doctype issue. Does the top of your page contain a valid doctype?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •