Advanced Search

Results 1 to 4 of 4

Thread: Slimbox Help

  1. #1
    Join Date
    Jul 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Slimbox Help

    3) Describe problem: This script works perfectly on my homepage, but when I tried to implement in the sub 'gallery' folder, the lightbox viewer gets stuck when opening up. I have copies of required files on each of the folders... please help, im on a deadline.

    the site is http://spaceshaping.kinetic-designs.net
    and http://spaceshaping.kinetic-designs.net/gallery
    Last edited by jscheuer1; 07-09-2008 at 06:22 PM. Reason: remove erroneous links

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,687
    Thanks
    43
    Thanked 3,129 Times in 3,095 Posts
    Blog Entries
    12

    Default

    This is not lightbox, it's slimbox.

    These are the externally linked script tags that appear on both pages:

    Code:
    <script type="text/javascript" src="js/effects.js"></script>
    <script type="text/javascript" src="js/application.js"></script>
    <script type="text/javascript" src="js/mootools.js"></script>
    <script type="text/javascript" src="js/slimbox.js"></script>
    However, the working page is only finding these:

    Code:
    <script type="text/javascript" src="js/mootools.js"></script>
    <script type="text/javascript" src="js/slimbox.js"></script>
    The non-working page is finding them all, and these:

    Code:
    <script type="text/javascript" src="http://cslingphotography.com/blog/wp-content/themes/csling_theme/javascripts/prototype.js"></script>
    <script type="text/javascript" src="js/effects.js"></script>
    <script type="text/javascript" src="js/application.js"></script>
    <script type="text/javascript" src="js/mootools.js"></script>
    <script type="text/javascript" src="js/slimbox.js"></script>
    Which are also in its source code. Apparently one or more of the 'extra' scripts is messing things up. I'd try getting rid of all of the external script tags from the non-working page, except these:

    Code:
    <script type="text/javascript" src="js/mootools.js"></script>
    <script type="text/javascript" src="js/slimbox.js"></script>
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Jul 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    i fixed those things you said, and i still can not get it to work, any other suggestions?

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,687
    Thanks
    43
    Thanked 3,129 Times in 3,095 Posts
    Blog Entries
    12

    Default

    It's working here in IE 7, FF 3, and Opera 9.5. Perhaps you need to reload the page and/or clear your browser's cache.

    This:

    Code:
    <script type="text/javascript">
    			window.addEvent('domready',function(){
    				Lightbox.init({descriptions: '.lightboxDesc', showControls: true});
    			});
    		</script>
    is causing an error though. Lightbox does not exist. You can probably safely remove it from the page. There was one other error in IE, but it may go away when you fix that. The Slimbox lightbox effect still worked even with the errors.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •