Results 1 to 4 of 4

Thread: Works in FF but not IE

  1. #1
    Join Date
    Apr 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Works in FF but not IE

    1) Script Title: scrollable iframe

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...ramescroll.htm

    3) Describe problem: Can't seem to get it to scroll in IE. I have changed the external.htm to a php file and the code I'm using is

    Code:
    <iframe id="datamain" src="product_images.php?products_id=<?php echo (int)$HTTP_GET_VARS['products_id'];?>" width=120 height=<?php echo 200 + ($listing['track_list_count']*16);?> marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no></iframe>
    That works, it gets and displays the right images for the product but it doesn't scroll. Works fine in FF (local & remote) and your example works remote OK in IE.

    I've searched and I think I found an answer but can't find it now. I think it is because I'm developing locally but when I upped it to my site it still didn't scroll. I'm sure it worked on Sunday.

    I must be doing something wrong but I don't know what. I can't give you a URL because it's a live ecommerce site

    Any help appreciated.

    Cheers

    Ian

  2. #2
    Join Date
    Apr 2008
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    srry, nevermind... I was wrong.
    Last edited by AKiraVos; 04-24-2008 at 09:09 PM. Reason: mistake, my bad

  3. #3
    Join Date
    Apr 2008
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by ianr_ric View Post
    1) Script Title: scrollable iframe

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...ramescroll.htm

    3) Describe problem: Can't seem to get it to scroll in IE. I have changed the external.htm to a php file and the code I'm using is

    Code:
    <iframe id="datamain" src="product_images.php?products_id=<?php echo (int)$HTTP_GET_VARS['products_id'];?>" width=120 height=<?php echo 200 + ($listing['track_list_count']*16);?> marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder=0 scrolling=no></iframe>
    That works, it gets and displays the right images for the product but it doesn't scroll. Works fine in FF (local & remote) and your example works remote OK in IE.

    I've searched and I think I found an answer but can't find it now. I think it is because I'm developing locally but when I upped it to my site it still didn't scroll. I'm sure it worked on Sunday.

    I must be doing something wrong but I don't know what. I can't give you a URL because it's a live ecommerce site

    Any help appreciated.

    Cheers

    Ian
    Please someone, anyone. It is something I'm doing wrong because I created a table in a blank HTML file, used external.htm and it worked. Added the blank html to my PHP page and it didn't.

    I have made a copy of my site in another folder so you can see it in action or not. Some images are missing due to lack of space but the prob can be seen. http://icr-records.co.uk/catalog Pick on any image and the page with the iframe is displayed. It doesn't scroll. Now try it in FF. It scrolls.

    Cheers

    Ian

  4. #4
    Join Date
    May 2008
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Scrollable IFRAME IE7 problem

    I have the same problme as you had. Did you find a solution to it?

    Hope you can help

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •