Advanced Search

Results 1 to 4 of 4

Thread: CSS TAB issues

  1. #1
    Join Date
    Nov 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default CSS TAB issues

    http://www.dynamicdrive.com/style/cs...rizontal_menu/

    I am using the tabs located at this link, i have saved the images to the appropriate folder within my site. I have changed to code to point at those images, yet only the "home" tab is complete...the other tabs are blank, only showing the words when I preview in IE..when I mouse over the word, for example, Im ouse over "forum" the tab appears...can someone point out what I am doing wrong?

  2. #2
    Join Date
    Jul 2006
    Location
    just north of Boston, MA
    Posts
    1,806
    Thanks
    13
    Thanked 72 Times in 72 Posts

    Default

    can someone point out what I am doing wrong?
    not unless you show us some of your code...
    either post the url to the code or use the [code] tags to embed it in a reply

  3. #3
    Join Date
    Nov 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    sorry about that...I left the links in the HTML portion alone, was going to update those once I got that tabs to show up in full

    <style type="text/css">

    /*Credits: By Santosh Setty (http://webdesigninfo.wordpress.com) */
    /*Posted to: Dynamic Drive CSS Library (http://www.dynamicdrive.com/style/) */

    .glossymenu{
    position: relative;
    padding: 0 0 0 34px;
    margin: 0 auto 0 auto;
    background: url(media/menur_bg.gif) repeat-x;
    height: 46px;
    list-style: none;
    }

    .glossymenu li{
    float:left;
    }

    .glossymenu li a{
    float: left;
    display: block;
    color:#000;
    text-decoration: none;
    font-family: sans-serif;
    font-size: 13px;
    font-weight: bold;
    padding:0 0 0 16px;
    height: 46px;
    line-height: 46px;
    text-align: center;
    cursor: pointer;
    }

    .glossymenu li a b{
    float: left;
    display: block;
    padding: 0 24px 0 8px;
    }

    .glossymenu li.current a, .glossymenu li a:hover{
    color: #fff;
    background: url(media/menur_hover_left.gif) no-repeat;
    background-position: left;
    }

    .glossymenu li.current a b, .glossymenu li a:hover b{
    color: #fff;
    background: url(media/menur_hover_right.gif) no-repeat right top;
    }

    </style>

    <ul class="glossymenu">
    <li class="current"><a href="http://www.dynamicdrive.com/"><b>Home</b></a></li>
    <li><a href="http://www.dynamicdrive.com/style/"><b>CSS</b></a></li>
    <li><a href="http://www.dynamicdrive.com/forums/"><b>Forums</b></a></li>
    <li><a href="http://tools.dynamicdrive.com"><b>Webmaster Tools</b></a></li>
    <li><a href="http://www.javascriptkit.com/"><b>JavaScript</b></a></li>
    <li><a href="http://www.cssdrive.com"><b>Gallery</b></a></li>
    </ul>

  4. #4
    Join Date
    Jul 2006
    Location
    just north of Boston, MA
    Posts
    1,806
    Thanks
    13
    Thanked 72 Times in 72 Posts

    Default

    use the[code] tags when posting code, please



    background: url(media/menur_bg.gif) repeat-x;
    make sure the image is in the sub-folder "media" from whereever the page is being ran.... eg

    if you are in your home web root folder. your file system would look like this

    Code:
    index.html (html page)
    somepage.html (html page)
    pageWithMenu.html (html page)
    media (folder)
     -- menur_bg.gif  (image file)
     -- someimage.gif (image file)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •