Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: css + Flash Gallery

  1. #1
    Join Date
    Jul 2005
    Location
    Planet Earth
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default css + Flash Gallery

    Hi,

    I have a css website into which I am trying to integrate a flash gallery but I am running into a problem.

    http://www.maraconservancy.com/gallery.html

    The flash gallery doesnt seem to load and if it does its taking too long(i think its a problem with flash detection) Kindly guide me
    On my computer it does work but the flash movie loads with a rather small aspect as compared to what I have made and the background doesnt match my websites background colour.

    Your assistance will be highly appreciated

    Regards
    Redice

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,954
    Thanks
    43
    Thanked 3,195 Times in 3,157 Posts
    Blog Entries
    12

    Default

    Your moo fx module (js/moo.fx.pack.js) is broken. The gallery (which should be independent of that) seems to load up fast enough, but doesn't seem to do anything. It either hasn't fully loaded, or just has no content. I loaded the flash gallery just by itself in one browser, but that didn't make it do any better.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  3. #3
    Join Date
    Jul 2005
    Location
    Planet Earth
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    wow... silly me didnt upload the xml file and the images :-s :OINK::
    Done that now, and it will give a better understanding of my problem. Also could someone kindly let me know how I may center the flash video as I have been unable to do that too :-s

    Thanks
    Redice

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,954
    Thanks
    43
    Thanked 3,195 Times in 3,157 Posts
    Blog Entries
    12

    Default

    Now the gallery loads up fine and works fine. Only two pictures though. Except in IE 7, it doesn't load (I have a lower version of Flash in that browser, could be the reason). You still have the same moo fx error from before. To center it use these styles in place of the current headerimage styles:

    Code:
    #headerimage {
    width: 400px;
    height: 400px;
    margin:0 auto;
    }
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  5. #5
    Join Date
    Jul 2005
    Location
    Planet Earth
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you sir.
    Managed to center it, but my flash movie is still smaller and surrounded by the white are :-s

    Redice

  6. #6
    Join Date
    Aug 2005
    Location
    Other Side of My Monitor
    Posts
    3,486
    Thanks
    5
    Thanked 105 Times in 104 Posts
    Blog Entries
    1

    Default

    The "white area" is your Flash Stage. I am guessing you are loading the images into a blank movie clip?

    I am willing to bet your setStage sizes are wrong in your ActionScript.
    {CWoT - Riddle } {OSTU - Psycho} {Invasion - Team}
    Follow Me on Twitter: @Negative_Chaos
    PHP Code:
    $result mysql_query("SELECT finger FROM hand WHERE id=3");
    echo 
    $result

  7. #7
    Join Date
    Jul 2005
    Location
    Planet Earth
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    my flash stage is 400x400 and the action script is set to resize the images within the 400x400 stage. It loads pretty well here

    http://maraconservancy.com/gallery.swf

    but just not within the webpage.

  8. #8
    Join Date
    Aug 2005
    Location
    Other Side of My Monitor
    Posts
    3,486
    Thanks
    5
    Thanked 105 Times in 104 Posts
    Blog Entries
    1

    Default

    Then you have some other boundaries on the div on the webpage. I haven't trolled through all the different JS files you have, but double check the ht. and width of the div and any div related restrictions for the swf file.

    The Flash works fine, so I can surmise it is either JS or HTML related problem.

    Good Luck
    {CWoT - Riddle } {OSTU - Psycho} {Invasion - Team}
    Follow Me on Twitter: @Negative_Chaos
    PHP Code:
    $result mysql_query("SELECT finger FROM hand WHERE id=3");
    echo 
    $result

  9. #9
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    28,954
    Thanks
    43
    Thanked 3,195 Times in 3,157 Posts
    Blog Entries
    12

    Default

    Yes, the Flash file works well in the full browser window. However the images in the gallery are set to be a percentage of the overall gallery size. Once you get the gallery onto the page, you have set its dimensions to 400 x 400, that's like viewing the gallery in a full browser window of only 400 x 400.

    If the gallery were to be coded slightly differently, it could possibly have the images take up more of the 400 x 400 space than it currently does.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  10. #10
    Join Date
    Jul 2005
    Location
    Planet Earth
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    hi,

    i finally got the images to load fully, but abit of my gallery is cut off from the left by about 9-12 pixels. Any ideas why?


    Thanks in advance

    Redice

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •