Results 1 to 2 of 2

Thread: Lightbox quit working

  1. #1
    Join Date
    Sep 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Lightbox quit working

    1) Script Title: Lightbox image viewer

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...tbox/index.htm

    3) Describe problem:
    I was making small edits to my site, unrelated to any component of the lightbox script. Could someone please look at the code on these pages and tell me what might be wrong. It was working perfectly. I updated the left nav using a library item in Dreamweaver and that's it.

    http://www.daltonmg.com/work/new_technology_work.htm

    http://www.daltonmg.com/work/whole_n...lgame_work.htm

    http://www.daltonmg.com/work/carving...arket_work.htm

  2. #2
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    Works in Opera (which now, unlike any other browser that I know of, allows both body onload and window onload), not in FF, probably not in IE. You have an onload conflict. I'd try, where you have this:

    Code:
    <body onLoad="MM_preloadImages('../imag . . .
    adding (red):

    Code:
    <body onLoad="initLightbox();MM_preloadImages('../imag . . .
    This could mess things up in recent Opera browsers though, by initializing lightbox twice. Just to be on the safe side, I would recommend also removing this:

    Code:
    addLoadEvent(initLightbox);	// run initLightbox onLoad
    from your lightbox.js file.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •