Results 1 to 5 of 5

Thread: IE and Animated Collapsible DIV

  1. #1
    Join Date
    Aug 2005
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default IE and Animated Collapsible DIV

    1) Script Title:Animated Collapsible DIV

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...edcollapse.htm

    3) Describe problem: In latest version of IE upon closing the div or slide up or however you want to describe it, the div will look like it's closing and then it gets almost closed and pops back open

    Any ideas on how to correct?

    Seems to work fine in latest ver of FF

  2. #2
    Join Date
    Sep 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I am having this exact issue. The script works in Firefox but is buggy in IE (6 and 7). On the initial page load, the DIV is open (though I specify it not to be) and when you click the link to open the DIV, it disappears suddenly and animates back open. When you click to close it, it closes but then shows back up instantly once done closing. I have this running in a php file that has a few variables and some other javascripts running but have disabled the other javascripts and only made the echos of the variables in php (everything else is pure html). Any suggestions? The examples work in IE fine, I just can't get them to work in the context of my page.

  3. #3
    Join Date
    Nov 2007
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question h !

    hi@all !!

    love this site and all itīs content ;-)

    I used the same script u guys used !

    In FF script is working properly !

    But in IE same problem as described before !

    tried every possible way... i cold imagine

    but same result all the time...

    the content shows up ! and not already collapsed as i set it..

    when you try to collapse it, it goes up to the closing point and it disappears suddenly and animates back open !!


    Please i would really build that script into my page..
    WC3 validated aso.. all checked working FINE in FF !!

    But for everyone else using IE this should work too !!

    HOPING for HELP !!!!


    cYa !

    regards...


    btw: sorry for my bad english, I am german..

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    IE is a little finicky with this script, requiring at least a valid URL HTML 4.01 transitional DOCTYPE and, if not valid markup, at least not markup that is wildly invalid. You can validate your markup here:

    http://validator.w3.org/

    But, even with some, or a lot of errors, you should be OK as long as you have a basically valid structure for your document. That means one and only one of each of the following type tags laid out in the following order:

    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd">
    <html>
    <head>
    <title></title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    
    </head>
    <body>
    
    </body>
    </html>
    If any of you folks need more help:

    Please post a link to the page on your site that contains the problematic code so we can check it out.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  5. #5
    Join Date
    Nov 2007
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    THX MATE !!!!!

    just added the <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

    parrt to my head specs and it works FINE in IE + FF !!!!

    really a BIG THX ! to the ultra fast support !

    Now i guess everybofy shoulld get this done ;-)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •