Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 55

Thread: Call lightbox from a flash file with buttons?

  1. #31
    Join Date
    Aug 2007
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I cant see where getURL("javascript:show(1)");
    calls on the images in your code.

    I Im trying to use several flash buttons to call there own groups of images?

    ie button1 will open group1 gallery / button 2 will open group 2 gallery

  2. #32
    Join Date
    Aug 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you for answering Charlene !

    It works perfectly but now the swf underlay dissapears totally !!!!!

    What can I do to let the swf visible behind the lightbox working ???

    Thank you in advance !!!
    Last edited by SAB++; 08-21-2007 at 01:37 PM. Reason: false

  3. #33
    Join Date
    Mar 2007
    Location
    Currently: New York/Philadelphia
    Posts
    2,735
    Thanks
    3
    Thanked 519 Times in 507 Posts

    Default

    You don't want the swf working under it. It's going to create a ton of problems for you. The main one being that your lighbox won't appear on top of it.

    If you still want to get rid of that functionality, you'll need to edit the lightbox js.

  4. #34
    Join Date
    Aug 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    You don't want the swf working under it
    >> In fact, I just want the swf doesn't dissapear from the screen.

    For example, this site : http://www.brainstorms.it/galleria/gallery_flash.html
    The swf behind stay in place.

    Concerning the lightbox.js, I'm too bad in javascript but I think it would be great to create a function like showImage() but for the swf or Element.visible (stuff.swf'); Something like that.

    If you know the code, you're welcome

    Thanks in advance

  5. #35
    Join Date
    Mar 2007
    Location
    Currently: New York/Philadelphia
    Posts
    2,735
    Thanks
    3
    Thanked 519 Times in 507 Posts

    Default

    You could just add a screenshot of your flash file as the background of the div. That would be an easy workaround...

  6. #36
    Join Date
    Aug 2007
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Why not ? good idea ! I'll try and by the way if I find a script I'll tell you.

    Thx a lot

  7. #37
    Join Date
    Aug 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by SAB++ View Post
    Thank you for answering Charlene !

    It works perfectly but now the swf underlay dissapears totally !!!!!

    What can I do to let the swf visible behind the lightbox working ???

    Thank you in advance !!!
    I'm having this same problem. When I trigger lightbox to open, the flash file completely disappears. Does anybody know what would cause this? If I were to guess, i'd say it's something in the object code for the flash file, but I can't seem to get anything to work. The object code I'm using to embed the flash is:

    HTML Code:
    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="100%" height="100%" id="using/website" align="middle">
        <param name="allowScriptAccess" value="sameDomain" />
        <param name="movie" value="fullscreen.swf" />
        <param name="quality" value="high" />
        <param name="wmode" value="transparent">
        <param name="scale" value="noscale" />
        <param name="salign" value="lt" />
        <embed src="fullscreen.swf" quality="high" scale="noscale" salign="lt" bgcolor="#535353" width="100%" wmode="transparent" height="100%" name="using/website" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
        </object>
    Thanks!

  8. #38
    Join Date
    Sep 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Wink

    Quote Originally Posted by raurey View Post
    I'm having this same problem. When I trigger lightbox to open, the flash file completely disappears. Does anybody know what would cause this? If I were to guess, i'd say it's something in the object code for the flash file, but I can't seem to get anything to work. ...
    This is a SETTING in lightbox.js -- because some browsers mostly on MACs have problems with layering of DHTML and FLASH... as far as I know there is NO Workaround for that problem... so you have to choose a consistent look for all browsers (flash hidden) or kind of broken look for some people on Macs with FF/Safari (flash visibible)... maybe others.

  9. #39
    Join Date
    Sep 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    hi,

    downloaded de source code, but i encounter a problem,

    this loads pictures from flickr, is there a possibility to load the pictures from a directory on the webspace of harddisk,

    where do i have to put the buttons to make the pictures appear?

    thanks

  10. #40
    Join Date
    Sep 2007
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    hi SAB

    could you please post the fla that you used in the example site,

    if it's too difficult to post it here, you could also send it to mail, schorrie01@hotmail.com

    thanks,

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •