Results 1 to 7 of 7

Thread: Cool tooltip II

  1. #1
    Join Date
    Aug 2008
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Cool tooltip II

    1) Script Title: Cool Tooltip

    2) Script URL (on DD): http://www.dynamicdrive.com/dynamici...mltooltip2.htm

    3) Describe problem:
    As I use the script in my page directly, it just works fine.
    As soon as I plug it into my joompla site, the position of the tooltip
    is calculated wrongly.
    X = ok, Y is about 400 pts to low. allways on the bottom of the window.
    I tried firefox and IE : both the same.

    I suppose it's some kind of problem with the header of the joomla page.
    there are a LOT of div's, some iframes etc.
    (actually the script is running in a iframe)

    So what would you suggest to attack this problem. I rather not change your script myself, then being excluded from any future upgrades.


    Thansk in advance for your help.
    Steven

  2. #2
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    2,023
    Thanks
    17
    Thanked 319 Times in 318 Posts
    Blog Entries
    3

    Default

    Please post a link to your site so we can take a look at your code.
    Eddy Proca
    I love Dropbox. Get it through my girlfriend's referral link (I reached my limit) and both you and her get 500 MB extra! Thanks and you're welcome!

  3. #3
    Join Date
    Aug 2008
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Ok here it is :

    http://www.tout-bien.com/index.php?o...id=28&Itemid=5

    Then click on the map of France, a new -detailed map will open.

    Steven

  4. #4
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    Follow the instructions, particularly:

    Step 2: Insert the below code into the <body> section of your page, outside any other tags, especially relatively or absolutely positioned elements:
    Easiest way is to put it either right before the closing </body> tag, or right after the opening <body> tag. Otherwise you will need to find another spot in the markup (if any) that is "outside any other tags".

    There could also be other problems, but this is usually the only issue in a case like this.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  5. #5
    Join Date
    Aug 2008
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Ok, that was done allready.
    The problem is that the page is loaded in an Iframe.

    If I have to do as you suggested, I have to adapt the code to find
    it in the main page (which is no problem)
    and I have to change the joomla installation (that is the templates
    i use (?) which is a big problem.

    In that case a rather adapt the script, to go from document
    references to window references.

    Steven

  6. #6
    Join Date
    Mar 2005
    Location
    SE PA USA
    Posts
    30,495
    Thanks
    82
    Thanked 3,449 Times in 3,410 Posts
    Blog Entries
    12

    Default

    There is no iframe in your page's source code as served.
    - John
    ________________________

    Show Additional Thanks: International Rescue Committee - Donate or: The Ocean Conservancy - Donate or: PayPal - Donate

  7. #7
    Join Date
    Aug 2008
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Ok, you're right.
    I found an emplemented the solution.

    Thanks a lot for your help.
    Steven

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •